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Abstract

Software developers interact with the Integrated Development Environment
(IDE) by issuing commands that execute various programming tools from source
code formatters to build tools. The aim of this thesis is to collect data on how
developers interact with the IDE while developing software, and to mine devel-
opers’ workflow from IDE usage using process mining techniques. To pursue
this goal research was conducted to investigate available IDE and tools. A com-
parison was made based on this research and a promising tool was selected. The
tool was capable of capturing developers’ interactions within IDE. However, it
had some limitations which needed to be overcome to change the perception on
usage data and to determine the requirements for improvement.

The first requirement was the enablement of the collection of developers’ in-
teractions within an IDE regarding influenced files and the enablement of the
collection of developers’ interactions through their source code. A further re-
quirement was to activate process mining. The desired improvements for the
tool to meet these requirements were designed and implemented. Finally, the
developed software was evaluated throughout a test case scenario which was
given to developers. The methodology to refine the retrieved experimental data
required was illustrated. The results of the methodology revealed an accurate
depiction of developers’ interactions and the analysis proved that mining devel-
opers’ workflow through their interactions within IDE is possible.
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Preface

This thesis was carried out at the department of DTU Compute, at the Technical
University of Denmark, in fulfillment of the requirements for acquiring an M.Sc.
in Computer Science and Engineering.

The goal of this project was to collect data on how developers interact with
an IDE while developing software and to mine developers’ workflows from IDE
usage using process mining techniques.

This report describes the project itself and discusses concepts involved. It anal-
yses in detail the software which was selected for expansion and features that
were developed during this project. In the end it presents the results of mining
developers’ interactions according to their IDE usage.
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Chapter 1

Introduction

Programming is not a way of implementing a solution, but it is a way of think-
ing. This intricate procedure requires a great amount of human memory and
cognition; thus, developers make use of IDEs which are environments responsi-
ble to ease software developing workflow. But, would it be possible to develop
huge software only by using a compiler and a code editor? If so, how would
development workflow be impacted if IDE did not exist and how long it would
take to develop software?

Developers’ workflow without an IDE becomes extremely slow and developers’
efficiency is notably decreased. Other remarkable advantages of using IDEs are
listed in [Ver17] and [Tra17].

Nevertheless, it seems that the process of software development has stagnated.
This is since IDEs usually tend to overload developers by providing a consid-
erable number of tools which result in a chaotic state as studies have shown
[MMRL16], [PR12]. Based on these, several researchers ([KMCA06], [FKA+05],
[MML15], [ZH13]), focused on understanding how developers operate to com-
plete their jobs: how they structure their tasks, how they apply their strategies
and how they use their tools. Their findings allowed modern IDE to begin
recognizing the complexity and the memory requirements for developers. How-
ever, despite these findings none of these tools can as yet take the developer’s
cognition into account [PR12].
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In addition, developers’ interactions have frequently been used by researchers
to examine developers’ behaviour, including [MKF06] which highlights the most
commonly used tools and [ML13a] which activated understanding of develop-
ers’ workflow. More specifically, researchers in [ML13a], developed DFlow for
recording development interactions within Pharo IDE.

Based on the afore-mentioned literature, it may be concluded that there was con-
siderable potential in exploring developers’ workflow within an IDE throughout
their interactions and way of thinking. Consequently, it was decided to further
investigate how the extraction of these interactions in a widely used IDE could
be executed.

1.1 Contributions

The following contributions to the body of knowledge that concern process min-
ing of developers’ workflow through IDE usage are:

• a proposal for different perception on usage data to relate developers’
interactions with influenced resources

• a design model and implementation of a tool capable of detecting and
recording developers’ interaction within a widely known IDE in regards to
influenced resources.

1.2 Structure of thesis

To begin with, Chapter 2 provides a more specific background on the prob-
lem and its origin. It goes through previous related studies within the area of
IDEs and the connection between a developer and an IDE. Next, knowledge
for available IDEs and plug-ins is captured unravelling their capabilities and
limitations. Selection between the most promising plug-ins is performed and
the selected plugin is deeper analyzed. In the end, a background regarding the
principles of process mining is provided.

Further, in Chapter 3 the goals are clearly stated and questions are raised re-
garding the current perception on usage data logs. An innovative perception
of process mining usage data is suggested. Improvements required to meet the
perception proposed on the chosen tool are described.
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Later on, the design decisions which were made to fulfill requirements stated
are defined and illustrated in Chapter 4. The design decisions can be sorted
in: design decisions for allowing process mining, for giving a new perception
on developers’ interaction within an IDE and also for giving a perception on
developers’ source code interactions.

Thereafter, in Chapter 5, an experiment is materialized to record a data set
with event logs derived from the improved version of the tool. These event logs
are being refined to be able to be imported in process mining tool. Afterwards,
the results accomplished are demonstrate and discussed in detail.

Finally in chapter 6, the thesis is concluded and an extensive look at future
work is taken.
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Chapter 2

Background and Theory

Since an IDE is very personal and is accustomed to developers’ preferences, gath-
ering information regarding interactions within an IDE is promising to reveal
developers’ workflow.

Before proceeding any further, it is absolutely required to build a solid back-
ground behind concepts used throughout the thesis related to IDE.

This chapter begins with section 2.1, which gives an introduction to how IDE
evolved through time i including the reasons proving IDE’s significance. In
addition this section describes the possible interactions of a developer within an
IDE.

Among the various IDE mentioned in section 2.1, Eclipse was selected for further
investigation in section 2.2. The capabilities of Eclipse and its advantages are
elucidated. Further, the nature of Eclipse plug-in development is enhanced
including an oveview on Eclipse available plug-ins

After conducting a research on plug-ins, Rabbit Eclipse high potential was no-
table and the decision to give a great amount of focus on that specific plug-in
was taken. In section 2.3 the architecture of the plug-in is presented to provide
a mutual understanding.
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Finally, a research is contained, in section 2.4, in regards to process mining
techniques and what was required in order for it to be enabled.

2.1 Integrated Development Environment

An IDE is a software application which aims to improve developers’ productivity
by facilitating application development. It consolidates the Basic tools (f.x.
source code editor, a compiler, debugger, etc) that developers need in order to
write and test software. To further understand capabilities and to gain insights
regarding IDEs availability, an investigation was carried out and is described
throughout this section.

Section 2.1.1 primarily consists of a brief historical description on how IDEs
evolved through time, and their major advantages. Next, section 2.1.2 analyzes
the possible interactions within IDE.

2.1.1 Overview of IDE

When the development via a console or a terminal became possible, ideas re-
garding IDE arose. The first steps towards IDE is traced back to Dartmouth
Basic which was the first language to be created with an IDE in 1964 [oDC18].
Dartmouth Basic IDE was command based, and without a graphical user inter-
face. However, it integrated editing, file management, compilation, debugging
and execution which are the necessary components to define an IDE.

According to [Ver17] Turbo Pascal, which was released in 1983 which integrated
an editor and a compiler for Pascal. Later on Microsoft’s Visual Basic (VB),
launched in 1991 and made the process learning programming relatively easy
and was used for teaching purposes. Further, followed Delphi in 1995,[Wik17]
which could run on 16-bit Windows and it could provide Object Pascal.

Throughout the years several IDE where developed (Codelite, Codeblocks, di-
alogblocks, Netbeans, Komodo, Xamarin) [pWT14]. Nowadays, the most known
and highly used nowadays are Visual Studio released in 1997 [Mic18] and Eclipse
released in 2006 [Fou18a]. Today, Top IDE index [Car16], which is a ranking
created by analysing how often IDEs are searched on Google, supports that the
three most used tools employed to develop source code are Eclipse released in
2004, Visual Studio released in 1997, Android Studio released in 2013 [Fou18a]
[Mic18] [2.518] .
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Although IDEs are striking through the top three, it is noticeable that a signifi-
cant amount of developers prefer to use highly configurable text editors such as
Vim and Sublime Text.

The different types of code, specific languages, cloud based, mobile application,
Apple or Microsoft development, led IDEs to expand in a variety of directions.
Consequently not all IDEs offer the same capabilities and the same collection
of tools. Therefore one must be selective when choosing an IDE, in accordance
to its development task and requirements.

Over the years, IDE have offered remarkable advantages to developers as men-
tioned in [Ver17] and [Tra17]. Some of these advantages for example are:

• Reduction of the setup up time required to configure multiple development
tools,

• Increment of development speed and efficiency by providing instant feed-
back for syntax errors or code insights,

• Improvement of program management by organizing resources, providing
a virtual representation of the project, and automatically adding appro-
priate imports.

• Increased the quality of programs by offering the ability for debugging,
testing and source control.

Overall these advantages of using an IDE have endorsed the productivity of
a developer and increased the number of possible interactions within an IDE
significantly. However the usefulness of interactions which are further described
in Section 2.1.2, IDEs lack effective support to browse between complex rela-
tionships of source code elements. This implies that developers spend 30% their
time navigating through a chaotic environment, thus, their productivity is being
reduced as supported by [MMRL16] [RND09] and [KMCA06]

2.1.2 Interactions within IDE

IDEs are highly used by developers these days to produce and maintain software.
Developers use IDE to read, navigate, understand and write code. In more detail
the developer interacts with IDE through low level events: mouse clicks and
keyboard shortcuts but also high level events which are facilitated by context
menus existing within IDE as mentioned in [KMCA06] and [ZH13]. A high
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level event is a series of low level events and it allows the developer to re-factor,
debug, navigate, test, and so forth without having to execute manually these
steps. These interactions are referred as usage data in [SMHF+15] and they
are an essential element of this thesis. Figure 2.1 represents the exchange of
usage data (high and low level events) produced by developer’s interactions and
corresponding logs are reported back from IDE.

Figure 2.1: Flow of usage data between developer and IDE.

An example to emphasize on what high and low level events mean as well as to
show the convenience IDE offer is the following The renaming of a class within a
large project. IDE provides contextual menus enabling fast and efficient changes.
Otherwise a series of low level events such as editing several files, compiling and
error seeking, executing and testing the correctness after the change will have
to be done manually.

According to [ML13b] and [Gu12] gathering all the IDE usage data provides
an additional perception on developers’ workflow. Analyzing and tracing the
workflow of a developer throughout usage data is a challenging matter which at-
tracted many researchers before, for example DFlow [USI14] [SMHF+15] [KMCA06].

To understand and investigate further developers’ workflow through their inter-
actions within an IDE the selection of an appropriate IDE was required and is
further described in Section 2.2.
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2.2 Eclipse IDE

Eclipse is undoubtedly one of the most powerful currently available IDE and this
is why it was selected as the IDE for this thesis. Eclipse offers various sub-project
development environments, i.e., IDE and Plugin Developer Environment (PDE)
and along with its structured framework it allows extensions and optimization
for tools to be easily applied.

The first part section 2.2.1 presents the Eclipse IDE with a brief introduction
of its capabilities including the major reasons for selecting this IDE. A basic
vocabulary was provided in regards to Eclipse IDE artifacts. Adding, the next
Section 2.2.2 gives an introduction to the highly adaptable Eclipse IDE and
the various approaches for developing plug-in tools. Attention is then given
on statistical existing plug-ins so as to select a base plug-in which allows the
captivity of developer’s interactions. Such plug-ins are analyzed thoroughly and
presented in Section 2.2.3.

2.2.1 Overview of Eclipse

Eclipse IDE is a powerful UI framework used by a respectively vast amount of
developers: to primarily develop Java applications or even to develop in other
programming languages, and to also develop documents and packages for other
software.

The standard SDK Eclipse distribution contains a base workspace with cer-
tain operations for Java development tooling plug-ins and layout. Thereafter
additional plug-ins can be included or created to allow the extension of the
workspace. As a result Eclipse can become a multi-function framework to be
used for: Embedded programming, C++ programming, javaBeans, Java appli-
cation, websites, or even develop additional Eclipse plug-ins and more [Wik18].

Even though Eclipse framework started as a replacement for visual age for Java
from IBM [Wik18], it became an open platform for integrating tools, editors,
views and plug-ins. Its source code is freely available and anyone can contribute
by building their own new plug-ins or by engaging in discussions regarding
integrated tools.

The most significant reasons for selecting the Eclipse IDE to analyze developers’
workflow are :

• It is the top ranked used IDE by developers [Bur09] and [Car16]
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• It is a home for tools, where you can build and integrate your own [Bur09]

• It is highly adjustable and enables the developers to construct its workspace
according to their preferences [Bur09]

• It is an open source framework where features and plug-ins are available
online so are the execution and source code files [Bur09]

• It is an open source Community [Fou18a], collection of technical profes-
sionals with a common interest in both using and contributing in the
evolution of the platform

Having these reasons in mind the framework of Eclipse was chosen as the IDE
for this thesis. Figure 2.2 illustrates Eclipse workspace and its surroundings,
to offer understanding for the various artifacts and also to define a common
vocabulary. Eclipse framework is consisted of a workbench window, which has
integrated basic elements such as views, text editors, menus and active perspec-
tives. [Fou18a]

Figure 2.2: A standard Eclipse workspace setup for a Java developer

A view is a window that enables the developer to observe and examine files
or projects, like Package Explorer, Outline and Console. In general, Eclipse
is in general filled up with context menus, the main menu is at the top of
the screen while views and explorers usually provide their own context menus.
Context menus enable the developer to customize the appearance of relevant
information or to provide supplementary capabilities.

A text editor is a smart editor which recognizes the programming language,
markups the syntax and allows the developer to easily modify and save files.
Editors share characteristics with views, but unlike views, editors do not have
context menus.
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A perspective has its own a set of elements views and editors and menus along
with an adaptable personalized layout for specific tasks such as debugging a
program.

To summarize these are the main artifacts usually provided by Eclipse initial
workspace setup for a java developer. These vocabulary terms are a starting
point to understand concepts of IDE as well as concepts supporting plug-in de-
velopment PDE. The real power of Eclipse lies within its capability of developing
plug-ins for itself and is presented in the following Section 2.2.2.

2.2.2 Plug-in Development in Eclipse

Eclipse offers the capability of developing or evolving additional tools for itself.
The PDE is based on the Open Services Gateway initiative (OSGi) technology,
and the software components are usually packaged and distributed as OSGi
bundles. OSGi bundles are very similar to standard JAR packages. An OSGi
bundle must contain a manifest file with the mandatory meta-data.1 This meta-
data includes a name, version, activator, dependencies, API and more.

Due to this technology, a good architecture is established for Eclipse. This is
why developers are easily able to extend their Eclipse IDE by creating new
additional operations or even improve the capabilities of already implemented
plug-ins. Based on this, a thumping range of plug-in tools are available in Eclipse
Marketplace client. These plug-ins can be classified in three categories according
to what they offer to a developer: assistance, customization/management and
statistics.

Assistance plug-ins can offer assistance to a developer while implementing a
software system, like in the instance of JRebel [Zer18] which allows developer’s
to reload code changes instantly or, the instance of Bytecode Outline [Los17]
which shows disassembled byte code of current java editor and allows developer’s
to have an inside look in the stack.

Moreover, there are customization and management plug-ins for example: Code-
Bubbles [Rei18] which is a front end of Eclipse designed to simplify programming
by generating working sets and grouping together related source fragments, or
Darkest Dark [Gen18] which simply enhance and changes the user interface color
to black.

Lastly, we have statistical plug-ins which provide statistics by gathering informa-

1https://en.wikipedia.org/wiki/OSGi

https://en.wikipedia.org/wiki/OSGi
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tion from Eclipse IDE and by using graphical representations. A representative
example is Metrics which calculates various statistics for your code [Flo16], or
Usage data collector which captures data to help understanding how developers
are using eclipse [Fou18b].

Although, as described above, Eclipse provides a variety of plug-ins to support
developers, usually this results in a chaotic environment. In an attempt to
reduce frustration created by the variety of plug-ins offered and in an effort
to improve a developer’s productivity, researchers in [GMR17] are aspiring to
understand the developers’ workflow by using statistical plug-ins and thereafter
developing Recommendation System in Software Engineers (RSSE)s. Following
ideas and concepts presented in [GMR17] the next Section 2.2.3 analyzes what
available plug-ins can contribute.

2.2.3 Plugin Availability and Analysis

Throughout research [GMR17] the need of developing context models that can
go beyond interaction events and common project artifacts is highlighted. A
model consisting of thirteen contextual factors is suggested in [GMR17]. Con-
textual factors are variables with precise domains of possible values that are
used to identify the context. The model characterizes developer situations from
several perspectives, namely who, what, when and where. Using this model of

M. Gasparic et al. / The Journal of Systems and Software 128 (2017) 200–219 205 
Table 2 
Context model. 

Category Contextual factor Contextual factor domain 
Who Developer unique identifier {Developer A, Developer B, ...} a 

Developer general experience {novice, competent, expert} 
Developer IDE experience {novice, expert} 

What Current activity {reading, editing, navigating, debugging, using version control, reviewing code, other} 
Previous activity {reading, editing, navigating, debugging, using version control, reviewing code, break, 

other} 
Type of the artifact under development {JavaScript file, XML file, Java class, Java method, ...} a 
Length of the artifact under development {short, medium, long} 
Complexity of the artifact under development {simple, medium, complex} 

When Time of the day {morning, afternoon, evening, night} 
Day of the week {Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday} 

Where IDE instance {Eclipse Luna, Subclipse, oXygen, ...} a 
Active user interface elements {{Java editor, XML editor, Project Explorer view}, {Java editor, Console view, Outline 

view, Project Explorer view}, ...} a 
User interface element with focus {Java editor, XML editor, Project Explorer, ...} a 

a actual domain depends on the collected data and cannot be predefined. 
cording to Dey (2010) , context is all about the whole situation rele- 
vant to an application and its set of users. Thus, primarily, we have 
to know who are the users, if we want to be able to relate differ- 
ent situations to them. In our model, the developer unique identi- 
fier factor refers to each individual IDE user. Potentially, this fac- 
tor could be replaced by a specific IDE installation or workspace 
instance, as can be seen also in the model evaluation results pre- 
sented in Section 5 ; however, since some developers use different 
IDE installations and workspace instances, and some installations 
and workspace instances are used by different developers, infor- 
mation about a developer is more informative. 

In knowledge-related activities, experience plays a very impor- 
tant role, even though the level of experience required to use a 
method or a tool is rarely explicitly defined ( Robillard, 1999 ). In 
software development, developers’ knowledge usually refers to the 
knowledge developers have about the system they are working on 
and their general software development experience ( Ying and Ro- 
billard, 2014 ). Specialized experience has the greatest impact on 
the productivity, while the effect of general experience on produc- 
tivity varies across different tasks ( Fong Boh et al., 2007 ). 

According to Fischer (2001) , for each user of a high- 
functionality application, such as IDE, there are well known 
concepts, vaguely known concepts, and unknown concepts; and 
vaguely known concepts can be learned faster and easier than un- 
known. We believe that higher general and specific IDE experience 
increase the size of vaguely known and well known concepts, re- 
spectively; the level of experience affects the IDE usage, and, con- 
sequently, may represent a relevant context. In our model, we use 
developer general experience and developer IDE experience contextual 
factors to characterize the level and the type of experience of each 
user. 

The developer general experience factor describes the level of 
overall software development experience of the user. We adopted 
the possible contextual factor values from Sillito et al. (2008) : de- 
velopers with five or more years of professional experience are 
classified as experts, developers that have between two and five 
years of professional experience are classified as competent, and 
developers with less than two years of professional development 
experience are classified as novices. 

In the developer IDE experience factor, we distinguish between 
experts and novices, similarly as Murphy-Hill et al. (2012) , who 
analyzed the acceptance of recommended IDE commands and de- 
tected significant differences between these two groups. We pro- 
pose to use the average number of different IDE commands used 
by an average IDE user as a threshold. Since it is IDE specific, we 
discuss it further in the next section. 

3.2. What 
The contextual factors in the what category capture information 

about what a developer is doing with an IDE and which project 
artifacts are used during or affected by her actions. Activities re- 
fer to a set of certain interaction events ( Maalej et al., 2014 ); in 
our case, the current activity factor describes what the developer 
is currently doing with an IDE. We based the values for this factor 
on Meyer et al. (2014) characterization of developers’ work that is 
based on observations of professional developers. Meyer et al. de- 
scribe six primary activity categories with related sub-categories: 
coding (reading, editing, and navigating), debugging, using version 
control (reading, accepting, submitting changes), testing performed 
outside the IDE, reviewing code, and other ( Meyer et al., 2014 ). We 
eliminate the “testing performed outside the IDE” activity as we 
are focused on a developer’s usage of an IDE. We also do not limit 
reading, editing, and navigation activities only to the source code 
artifacts, but consider the activities performed on any kind of arti- 
fact accessed inside an IDE. As “other” we classify all the detected 
IDE interactions that are not mapped to any other activity. 

Prior to whatever activity a developer is currently undertak- 
ing, a developer may have undertaken a different activity or may 
have been idle. We capture this information with the previous ac- 
tivity contextual factor. The possible values of the previous activ- 
ity are those that can be assigned to the current activity factor 
and “break”. 8 As previous research has shown, the interruptions af- 
fect the behavior of developers and as resumption activities differ 
from regular development activities ( Parnin and Görg, 2006; Parnin 
and Rugaber, 2009 ), we include the “break” value in the previous 
activity to better describe whether a developer has continuously 
worked in an IDE or not, and thus has to regain the previous men- 
tal state. 

The artifact under development, i.e., the object of the per- 
formed activity, has long been recognized as a relevant context in 
the software engineering community ( DeLine et al., 2005; Holmes 
and Murphy, 20 05; Robillard, 20 05; Shimada et al., 2009; Warr and 
Robillard, 2007 ). The artifacts can be represented at different lev- 
els of granularity, for instance, as files as by Singer et al. (2005) or 
Java elements (e.g., classes, methods, fields, methods calls) as by 
Kersten and Murphy (2006) . Furthermore, we can use exact identi- 
fiers of source code elements, such as absolute paths and (unique) 
identifiers, or abstract descriptions, such as complexity measures. 

8 Breaks are not included in the current activity , because developers do not inter- 
act with an IDE during the break. 

Figure 2.3: Context Model [GMR17]

contextual factors (see in Figure 2.3), as a main criteria along with taking into
account the maintainability and adaptability of the plug-in, an evaluation for
the capabilities of plug-ins can be derived.

Concerning the plug-ins mentioned before, they are mostly directed in gath-
ering statistics and observing the usage of artifacts by recording activity and
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interactions of a developer while developing a software system.

After conducting a research on available plug-in tools, through GitHub and
the Eclipse Market, the most similar which could be used as a basis and/or be
combined here are listed below and an evaluation with regards to the set criteria
is done.

• Fluorite

• Rabbit

• Metrics

• Mylyn

• Time Keeper

• ITrace

• Usage Data Collector

Fluorite is a plug-in developed in the School of Computer Science at Carnegie
Mellon university [YM11]. Its purpose is low level event logging for Eclipse
when using the code editor. In other words, events such as: character type, text
cursor movement, selected text modification, as well as, all the other available
Eclipse commands that can be called for an editor.

In Figure 2.4 an example representing the data from Fluorite depicted from
[YM11] is shown. By using the logged data, Fluorite can provide full reproduc-
tion of each source code file that has been used during a programming session.
Fluorite could potentially be used to extract developers’ source coding activity
since it enables the detection and measurement of time for various usage patterns
or events of interest like "typo correction". Among their findings, the authors
provided empirical evidence that editing source code is different from editing
textual documents. The authors also studied the distribution of keystrokes
reporting that backspace and arrows are the most frequent keys pressed by
developers.

However, this plug-in seemed promising for investigating sequences of low level
events and detecting coding strategies for code editor, it was not selected for
further exploitation. The main reason for not selecting this tool was its disabil-
ity of recording interactions of the developer with an IDE since this tool only
focused in capturing code editor interactions. A less important reason causing
the rejection of this plug-in was the massive amounts of low level events which
were generated and the unobtainable source code.
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annotate  a  videotape.  FLUORITE  can  also  be  useful  for 
motivating new tools. Ko et al.  laboriously hand­analyzed 
videotapes of code editing in their study of Eclipse editing 
[13],  and  showed  that  people  spend  significant  time 
scrolling, which motivated interesting new tools. FLUORITE 
will provide an easier way to get such data, and thus might 
help  motivate  other  ideas  for  new  tools  that  would  help 
programmers in the future. In addition, we anticipate in the 
future that FLUORITE’s logging and analysis may be used in 
real­time to support novel code editing operations that will 
depend on the history. 

2.  Related Work 

There are many different sources of developers’ usage data 
each with its own strengths and weaknesses. In many cases, 
FLUORITE can be used to complement the shortcomings of 
those methods. One way  is  to  directly  ask  the  developers 
who regularly use the target programming language or tool 
through interviews or surveys. Although these methods are 
effective and the investigators can get useful insights about 
the target feature,  the responses from the subjects may not 
be  reliable.  For  instance,  many  operations  are  performed 
quite automatically by the developers, so it is possible that 
they could report that they use a feature a lot but could not 
remember the specific occasions. 
Another  way  of  gathering  usage  data  is  performing 

contextual  inquiries  or  experiments  in  lab  settings. Often, 
the participants are  required  to  think aloud while perform­
ing their  tasks, and their screen and voice are recorded for 
further  analyses.  However,  the  experimenter  must  then 
manually inspect the videotape (as was done in [6, 13, 15, 
16])  in  order  to  analyze  the  results,  which  can  be  time­
consuming and error­prone. 
Usage  data  can  also  be  obtained  by  mining  software 

repositories  and  their  revision  histories. Many  researchers 
have  been  used  this  method  to  gain  insights  about  code 
clones  [4, 5, 12] and how  the developers  refactor  [11, 18, 
21].  There  is  plenty  of  available  data  in  the  open  source 
software repositories and from industry, and the data can be 
analyzed  automatically.  One  problem with  this  method  is 

that  we  still  cannot  know what  events  happened  between 
two consecutive revisions. Instead, we can only infer what 
types  of  commands  the  developers  might  have  used  to 
change the code from one revision to the next. 
Mylyn keeps  track of  the user  interaction history  inter­

nally  in order  to derive  the  task context  [9, 19]. Using  the 
Mylyn Monitor API [2], investigators can retrieve the user 
interaction  data  for  their  own  analyses.  FLUORITE  differs 
from the Mylyn Monitor in that FLUORITE focuses more on 
the  details  of  the  user  interaction  in  the  code  editor, 
whereas  Mylyn  Monitor  collects  more  abstract  user 
interaction data on  the entire  IDE. For example, when  the 
developer selects a class from the package explorer, Mylyn 
Monitor  logs  that  there  was  a  selection  event  from  the 
package  explorer  with  the  name  of  the  selected  class, 
whereas FLUORITE logs exactly which file was opened, and 
the offset and length of the highlighted text (i.e., the name 
of the class) in the file. 
The  Eclipse  Usage  Data  Collector  (UDC)  is  another 

useful  source  of  developers’  Eclipse  usage  data  [1].  The 
UDC collects usage information from all  the Eclipse users 
all over the world who consented to upload their usage data 
to  the  UDC.  The  UDC  provides  several  usage  reports 
including  the  commands  report.  These  reports  have  been 
used  by  many  researchers  [18,  20].  However,  the  com­
mands report from UDC can be misleading because it fails 
to capture some important commands executed in the code 
editor.  It  ignores  many  of  the  most  frequent  keyboard 
commands such as navigating source code with arrow keys 
and deleting the previous character with the backspace key 
because  they  are  not  explicitly  bound  as  shortcuts  by 
default.  In  contrast,  FLUORITE  collects  all  commands 
regardless of the use of their shortcut keys. Also, with UDC, 
you cannot find out anything about sequences of commands 
or  specific  parameters  of  commands,  since  UDC  only 
reports the number of occurrences of each command. 
Syde  and  Replay  are  tools  for  Eclipse  that  can  record 

fine­grained change history of Java­based systems in multi­
developer  settings  [8].  These  tools  are  intended  to  help 
developers understand the code’s evolution, but they could 

 
Figure 1. Example log generated by FLUORITE. The developer (1) moved the cursor by clicking mouse button, (2) selected 
one line by SHIFT + DOWN, (3) deleted selected code using the DELETE key, and (4) saved the file. Each event has its own 
parameters, and the whole deleted text is listed in DocumentChange event. 

<Command __id="2" _type="MoveCaretCommand" caretOffset="142" docOffset="142" timestamp="3977"/> 
<Command __id="3" _type="EclipseCommand" commandID="eventLogger.styledTextCommand.SELECT_LINE_DOWN" 
timestamp="5598"/> 
<DocumentChange __id="4" _type="Delete" docASTNodeCount="22" docActiveCodeLength="125" docExpression-
Count="10" docLength="151" endLine="9" length="39" offset="142" startLine="8" timestamp="7186"> 
  <text> 
    <![CDATA[  System.out.println("Hello World!"); 
 
]]> 
  </text> 
</DocumentChange> 
<Command __id="5" _type="EclipseCommand" commandID="org.eclipse.ui.edit.delete" timestamp="7202"/> 
<Command __id="6" _type="EclipseCommand" commandID="org.eclipse.ui.file.save" timestamp="8099"/> 

Figure 2.4: Fluorite: Example of data log collected

Usage Data collector is a framework for collecting information regarding
usage data of Eclipse IDE.

It was originally build by the Eclipse Foundation, as a way to measure how
the community was using the IDE. Information for views usage, editor usage,
changes of perspectives and actions invoked are recorded by monitors which
also use a time-stamp. In Figure 2.5 an example of a data log entry is shown
[SMHF+15]. Moreover this plug-in also collects basic information about the
run-time environment (OS, system architecture, window system, locale, etc).
This information are uploaded periodically to servers hosted by The Eclipse
Foundation with the purpose to be processed in a later stage [Fou18b]. This
project was shut down eventually due to resource constraints since hundreds of
thousands of Eclipse users uploaded data, the executable code for this plug-in
remains available as well as the collected data is available upon request.

3.1. Eclipse Usage Data Collector

This section outlines how to collect IDE usage data using Eclipse’s Usage Data Collector (UDC).4

The UDC framework was originally build by the Eclipse Foundation, as a way to measure how the
community was using the Eclipse IDE. While UDC was included in official Eclipse releases and data was
collected from hundreds of thousands of Eclipse users between 2008 and 2011, the project was eventually
shut down, and UDC was removed from official Eclipse releases. However, the source code for UDC
remains available for collecting data.

3.1.1. Collected Data

The Eclipse Data Collector records the following types of Eclipse information:

• The run-time environment, such as the operating system and Java Virtual Machine.

• Environment data, such as which bundles are loaded and when Eclipse starts up and shuts down

• Actions and commands that are executed, via menus, buttons, toolbars, and hotkeys.

• Views, editors, and perspectives that are invoked.

Let’s look at an example of an event that UDC produces on a developer’s machine:

what kind bundleId bundleVersion description time

executed command org.eclipse.ui 3.7.0.v20110928-1505 org.eclipse.ui.edit.paste 1389111843130

The first column tells us what kind of thing happened—in this case, something was executed. The
second column tells us what was executed—in this case, a command. The third column tells us what the
name of a bundle (a set of resources and code installed in Eclipse) this event belonged to—in this case,
Eclipse’s user interface bundle. The fourth column gives us the version of the bundle. The fifth tells us
the name of the command that was executed—in this case, paste. The final column, a unix time-stamp
that tells us when the command was executed, in Greenwich Mean Time—in this case, January 7th,
2014 at 16:24:03 GMT.

3.1.2. Limitations

Apart from general limitations of collecting usage data (Section 5), one significant limitation of UDC
that we have found is that sometimes it has unexpectedly incomplete data. For example, in planning
for a study involving when people ran their JUnit tests, we found that UDC recorded an event when
the “Run > Run As > Run as JUnit Test” menu item was selected, but not when the “Run As” button
was pressed on the toolbar. We suspect that the reason has to do with how different user interface
accordances invoke the same functionality. In general, when you are planning on running a study with
UDC, be sure to know what types of events you are looking for, and test them to make sure UDC
captures those events.

3.1.3. How to Use It

Collecting usage data is fairly straightforward with Eclipse UDC, and we describe how to do so here.
We also include an accompanying screencast that shows the basics.5

Gathering Data Using the UDC Client.. Let’s talk about how data is collected on a developer’s machine.
Since UDC was last included in the Eclipse Indigo SR2 release,6 if you have the option of which Eclipse
to use, we recommend downloading that version. By default, UDC starts collecting data when Eclipse
is start up. You can verify this by going to “Windows > Preferences”, then select the “Usage Data
Collector” item (Figure 1). The Enable capture option should be checked.

4http://www.eclipse.org/epp/usagedata/
5http://youtu.be/du4JTc9UB-g
6(http://www.eclipse.org/downloads/packages/release/indigo/sr2

Figure 2.5: Usage data collector: Example of data log collected [SMHF+15]

This plug-in tool records relevant information required for this thesis and for
this reason is valid and useful candidate by achieving a significant amount of
contextual factors 2.3. The source code was not obtainable and therefore the
usage of this plug-in as a basis for this research was rejected. According to
[SMHF+15] another inconvenience of this tool, is the fact that sometimes in-
complete data are captured. This is because not all key bindings, menu or main
toolbar bindings are addressed.

Metrics [Flo16] is a plug-in that calculates around 20 metrics for your code dur-
ing build cycles, warns the developer of range violations for each metric, plus,
it provides an XML file that contains the information. What is more, it pro-
vides representation of these metrics in tables inside the Eclipse IDE and also
generates dependency graphs. The mentioned calculated metrics for instance
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are McCabe’s cyclomatic complexity, number of elements (classes, children,
interfaces,statements, fields), depth of inheritance,etc. These metrics provide
information related to experience and to programming style of a developer as
referenced and further explained in [LW05].

This plug-in source code can be found online in [Git18] and in the Figure 2.6 a
representation of the mentioned calculated metrics is illustrated.

Figure 2.6: Metrics: Example of data collected [LWH05]

Metrics is analysing static code and although it can offer a perception of the
experience of the developer and the complexity of the current implemented
software system, it is not able to capture developers’ current activity, therefore
it was not selected.

Mylyn is a subsystem in Eclipse used for task management.[Com18] The orig-
inal name of this project is Mylar, and was used in studies such as [MKF06].
Mylyn offers a task-focused interface shown in figure 2.7 (f.x. fixing bugs, new
features, problem reports) to reduce irrelevant information to a task and makes
multitasking easier. Mylyn monitors programming activity to create a "task
context" in relation to workspace and automatically links all relevant artifacts
to the task-at-hand. Mylyn allows developers’ tasks to be organized and moni-
tors its activity. It provides awareness for the progress of tasks, and increases the
productivity by reducing unnecessary navigation, searching and scrolling. Fur-
ther Mylyn allows the creation of graph elements and relationships of program
artifacts.

As an addition to Mylyn plug-in, was TimeKeeper which is responsible to
track time, and report how long a developer worked on a certain task, and
open a workweek view. Together these two plug-ins form a strong organiza-
tion and management of working environment. The source code for Mylyn and
Timekeeper plug-ins are available online and located at [Git11] and [Git17] re-
spectively.
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Figure 2.7: Mylyn: Example of provided interface

Even though Mylyn integrated with TimeKeeper tool and they seemed promis-
ing, the main disadvantage of using this project was that important information
of developers’ interaction with IDE were not captured. These information are for
example: switching between views or switching between perspective. Therefore
this tool was not selected.

iTrace is a tool integrated with an eye tracker to determine the type of element
one is looking at. iTrace was released as open source project in June 7th 2015.
[Uni15] While the user is reading a source code file, the tools is recording the
eye movement and fixations and is able to identify the source code element for
example if the user is looking at a method, or an if statement, etc. iTrace allows
horizontal and vertical scrolling and is able to retrieve information only when
the code is static and no interactions with the IDE through keyboard or mouse
are happening. After a recording session of iTrace a data log with the fixations
on the current java editor is provided in an XML form (see figure 2.8).

iTrace capability to identify source code elements by using eye movement is
remarkable and the source code is available online [Git15a]. However, since
developers’ current activity is required to be captured to understand developers’
workflow, tracking only when user is reading results is a great limitation.

Rabbit Eclipse is a statistics tracking tool which provides developers with
information regarding their interactions within Eclipse IDE by recording low
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3.1 Session Creation
The session information consists of a generated session ID,

the session purpose (new feature, bug fix, refactoring, gen-
eral comprehension or other), and a longer session descrip-
tion. In addition to this, the developer ID with an optional
developer name is requested. Session information is required
before tracking starts.

3.2 Calibration
Every eye tracker needs to be calibrated before use. Dur-

ing calibration, the user is asked to look at several dots that
appear on the screen while the eye tracker uses the user’s
eye features along with its 3D eye model to calculate gaze
data. iTrace uses a 9-point calibration mechanism, interfac-
ing with the eye tracker’s native libraries to calibrate. When
calibration is complete, iTrace displays the results of the
calibration so that the user is able to verify the calibration
quality. The user can accept the calibration, or recalibrate.

3.3 Displacement Adjustment
In order to check for displacement or drift, iTrace sup-

ports a crosshair feature. When enabled, it displays a green
crosshair showing where the user is looking. For some users,
there is always some displacement of the eye gaze as shown
by the crosshair vs. the actual point looked at on the screen.
We test this by asking the user to look at certain words at
the top left, bottom left, top right and bottom right after
calibration. If the actual eye gaze is off from the intended
position, one is able to adjust the displacement on the x
and y axis as needed to bring the crosshair in line with the
user’s gaze. This displacement setting is used throughout
each session. It is not always necessary to adjust for drift
and should be used only when required.

3.4 Source Code Entity Level Tracking
iTrace supports fine-grained tracking of software artifacts

at the line and word level. In particular, emphasis is given
to source code as it is the most structured and semantically
rich artifact. The current iTrace model is able to map gazes
to source code entities (SCE) types such as classes, meth-
ods, variables, comments, method invocations, conditional
expressions, and enum, import, for, if, while, and switch
statements. For each of these types, it also states how the
SCE type is used in the code, i.e. a declaration vs. an in-
vocation. For example, if a user looked at a method call, it
would be considered a use of the method type.

3.5 Raw Data Exports
The number of gazes recorded by iTrace depends on the

number of samples per second output by the eye tracker.
Each gaze recorded by the eye tracker is used to generate
a gaze response object. iTrace currently supports gaze re-
sponse export into JSON and XML. An example gaze re-
sponse in XML format is shown in Figure 3. Properties of
the gaze itself, such as time, pupil diameter, validation, and
(x, y) coordinates, are stored as attributes of the response

element. Of these properties, all except system_time and
nano_time are read from the tracker. system_time is the
POSIX time on the host system expressed in milliseconds,
and nano_time is a high-precision time expressed in nanosec-
onds. The type attribute reports the region of the Eclipse
UI where the gaze fell. In the example, the gaze was in a
text editor, so the response element has some additional

Figure 3: An iTrace gaze response record.

attributes, including the filename, line, column, editor font
height in points, line height in pixels, and the (x, y) coor-
dinates of the upper left corner of the line. For Java files,
the Eclipse AST is queried to determine the source code el-
ements on which the gaze fell. This step is necessary, since
relying only on the line number would not be accurate if the
content of the file is changed during a tracking session.

In the example, the sce elements, sorted from most spe-
cific to least specific, report the types of the source code
elements, how they are being used, their positions within
the file, and the number of characters comprising the source
code elements. In this case the gaze fell on a call to the
method java.lang.String.length() in the declaration of
the trim variable, inside an if statement in the canonPath

method, within the tasks.MiscUtilities class.

3.6 Fixation Exports
In eye-tracking terminology, a fixation [6] is when the eye

stabilizes for a certain duration at a particular point of inter-
est. iTrace calculates fixations by running a basic fixation
filter on the raw data. In simple terms, a set of raw gazes
that fall around the same area are grouped and merged to-
gether to form a fixation record, along with the fixation start
time and the duration.

4. USAGE SCENARIOS
The usage scenarios of iTrace fall into two broad cate-

gories. First, it can be used as a method to assess and learn
about how developers navigate and look at different software
artifacts. Second, the data can be used to inform software
development tasks. An example of iTrace being used in each
of these two scenarios is described below.

4.1 Program Comprehension
iTrace has recently been used by Kevic et al. [4] to inves-

tigate detailed developer behavior while performing realistic
change tasks on a large open source system. The study
was conducted on 22 developers. To investigate the added
benefit of data generated from iTrace, the study compared
eye tracking data with Mylyn interaction history data, both
of which were gathered simultaneously. The authors found
that iTrace does capture more contextual data on source

956

Figure 2.8: iTrace: Example of logged data [SWW+15]

and high level events. The information is then displayed to developers by using a
graphical representation and also data logs. (see figure 2.9 and 2.10). Therefore,
tracking current activity of a developer within the IDE is possible.[Cod11]

	

Figure 2.9: Rabbit Eclipse UI

Rabbit eclipse carries similar ideas to Usage data collector mentioned before.
Even though that its development was terminated, the source code was available
on git-hub [Git15b].

Rabbit proved to be a good candidate for this thesis by achieving also a sig-
nificant amount of contextual factors 2.3. The source code was obtainable and
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Figure 2.10: Rabbit Eclipse: Sample of recorded event logs

easily adaptable therefore the usage of this plug-in as a basis for this research
was accepted. Further reasons behind this decision, as well as how the plug-in
operates, are explored and more detailed analyzed in section 2.3.

2.3 The focal plug-in - Rabbit Eclipse

This section aims to provide understanding regarding how Rabbit Eclipse plug-
in operates. Firstly, an overview is contacted providing the plug-in’s capabilities
and limitations in Section 2.3.1. Then, an effort to establish mutual concrete
understanding for plug-in’s architecture is analyzed in Section 2.3.2. To achieve
that, common usage scenarios for the plug-in and the main actors to the system
are described. Further, the architecture of Rabbit Eclipse is depicted and the
functionality of the main components is discussed.

2.3.1 Overview of Rabbit Eclipse

Rabbit Eclipse is a statistics plug-in and is responsible to collect the various
usage data from the interactions performed by a developer in Eclipse IDE over
a period of time. [Cod11] [jax10]

Rabbit Eclipse is a semi-dynamic recording tool which means that even though
it silently runs in the background and gathers usage data these are only avail-
able when requested. The usage data become visible in log files, or graphical
representation. These logs contain different types of interactions which are com-
mand usage; and time spent using tools such as: resources, perspectives, java
elements, sessions, editors and views, launches and tasks within Eclipse.
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Rabbit Eclipse in an effort to be more precise, it collects usage data only when
Eclipse is active. In other words, if the window of Eclipse is not focused or no
keyboard/mouse event has occurred during a particular amount of time then
Rabbit tool consider the developer as idle and pauses tracking activities. In this
way Rabbit provides more accurate data.

Due to the mentioned capabilities of deriving event logs with regards to devel-
opers’ activity as well as detecting when a developer is idle led to the choice of
modifying and extending this plug-in.

The main advantages behind the selection of Rabbit Eclipse as a base plug-in
were:

• the well-structured provided online source code which could be easily un-
derstood and interpreted [Git15b]

• the availability of the main developer who willingly responded to emails.

Rabbit Eclipse offers these advantages and proves to be a valuable base for
gathering usage data, but it also had some particular limitations.

Command’s interactions within Eclipse IDE can be triggered in various ways,
either by key-bindings, by contextual menus or mouse clicks. These command’s
interactions are further analysed by Eclipse [Bur09]. Using the information from
the book an analysis in regards to which command interactions are covered by
Rabbit Eclipse was undertaken. The results were satisfying sinceRabbit Eclipse
was able to capture the most commonly used commands [SMHF+15] A further
analysis of the results regarding this procedure is presented in Appendix A.1.

Today’s developers as mentioned in [MKF06], are using only a small portion of
commands available by Eclipse. Therefore, this limitation was neglected.

Moreover, Rabbit Eclipse was not able not recognize adjustments in terms of
layout. Interactions such as maximizing window, minimizing window and ad-
justing workspace are not recorded. However, this limitation was not an issue,
since interactions concerned with layout adjustments where out of the scope for
this thesis.

As a result these limitation did not overshadow the Rabbit Eclipse advantages
and therefore it was selected as the base plug-in for the thesis. Further, in the
next section 2.3.2 the architecture of the plug-in is elaborated.



20 Background and Theory

2.3.2 Architecture of Rabbit Eclipse

This section is destined to accomplish a mutual understanding of how Rabbit
Eclipse operates, since no particular documentation of the plug-in’s architecture
was provided. An advantage of using Rabbit Eclipse was the well-structured
open source code provided which enabled the ease of carrying out a study on
its source code. Throughout this study the creation of a model presenting the
flow of the system was possible and is displayed in Figure 2.11.

Figure 2.11: Model: Rabbit-Eclipse

The general followed scenario is that a developer is implementing a software
within Eclipse IDE, and generates various interactions of low and high level
events as described in section 2.1.2. When an interaction is initiated, Rabbit
Eclipse is triggered to capture, and analyse the interaction. These interactions
are then stored in event logs while they are exported and upon request of a
developer Rabbit Eclipse provides captured events in a graphical view.

To analyse further the system, two kind of actors interacting with the Eclipse
IDE, i.e., developer and plug-in are defined.

Developer: is a person who uses Eclipse IDE and could be running the envi-
ronment through any of available operating systems (Windows, Linux, MAC).
The developer does not know how to interact directly with plug-in for recording
but it is only capable of obtaining through the provided UI the metrics captured.
A developer can be an amateur or an expert who would like to get insights in
regards to its own development workflow.

Rabbit Eclipse is a plug-in on the other hand, which was created to capture
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activities within Eclipse IDE. The tool is built to communicate and record the
data inserted in the Eclipse IDE by keeping a data structure which will then be
used to output the information.

In Figure 2.12 aims to provide an idea of the most significant use cases which
are accounted, for the two actors are demonstrated. The use cases for develop-
ers’ interactions within Eclipse IDE are for example: execute commands, run
program, debug a program,etc. On the other hand the use cases in regards to
Rabbit Eclipse are detected user idle, track usage data, present usage data, etc.

Figure 2.12: This figure represents an abstracted overview of use cases.

Using this information of the general scenario and how actors interact with the
system the Figure 2.13 was created to represent Rabbit Eclipse architecture. The
depicted architecture is divided into unit sections: data structure, interaction
with developer, interaction with Eclipse IDE, interaction with output logs, an
XML output organizers and connecting handlers. Subsequently, these units are
further analyzed to explain the system thoroughly.

The data structure of Rabbit Eclipse is composed of the data and event units
shown in Figure 2.13. The selected data structure is arranged with Immutable
objects 2 and using Key Map Builder3 which provides consistency of information

2https://docs.oracle.com/javase/tutorial/essential/concurrency/immutable.html
3http://lkumarjain.blogspot.dk/2013/03/why-map-key-should-be-immutable-object.

html

https://docs.oracle.com/javase/tutorial/essential/concurrency/immutable.html
http://lkumarjain.blogspot.dk/2013/03/why-map-key-should-be-immutable-object.html
http://lkumarjain.blogspot.dk/2013/03/why-map-key-should-be-immutable-object.html
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Figure 2.13: Architecture of Rabbit - Eclipse plug-in

by enabling the defensive programming technique which provides a safe usage
from multiple threads. This means the objects won’t run in race conditions
resulting modified/corrupted states and also the objects can be easily shared by
references.

The data unit contains information for interactions which has already been
recorded from a previous session, whereas the event unit contains information
which has just been recorded from developer’s current activity. The structure of
event unit is shown in the Figure 2.14. This unit consists of a variety of classes.
At the top of the hierarchy is DiscreteEvent class and ContinuousEvent class
which distinguish between the main types of interactions recorded, i,e. instant
and continuous interactions. Command and Breakpoint are listed as Discrete
interactions. On the other hand, interactions such as switching between files,
views, perspectives, launching, java elements and session inherit from Continu-
ousEvent since the duration for such activities is relevant.

Further, the most important represented unit in Figure 2.13 is called Trackers.
These units run silently in the background and record developer’s interaction
within Eclipse IDE.

Due to this, and as displayed in figure 2.15 recorder, observer and listener classes
are used in order for tracker units to be notified when changes occur.
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Figure 2.14: Event Classes

At the top of the hierarchy lies the AbstractTracker class which defines the nec-
essary abilities of each tracker. These abilities are the collection of interactions,
their analysis, filtering and storage.

Each tracker unit is responsible to record a different type of interaction and
these types were described previously by the events structure. For example
the Command tracker is responsible to explore how often each command is
used (cut, copy, paste etc.), whereas, Part tracker handles time spent using
different artifact within Eclipse (Java Editor, Outline View, Project Explore
etc.) Also, perspective tracker is estimating how long different perspectives
have been used such as Debug, Java Browsing, GitHub etc. Moreover, launch
tracker is related to activities as application runs and debug runs, all relevant
files to these activities are recorded as well. Sessions tracks down how much time
was spent using Eclipse in total. Further, File tracker focuses on how long each
file, project and other resources have been used. Rabbit Eclipse tracker units
integrate also with Mylyn and as a result they also keep track of tasks that are
listed in Mylyn. Lastly the time spent on Java Elements (classes, methods) is
also captured.

These tracker units along with data handlers as presented in Figure 2.13 when a
developer requests or when eclipse is open/closed will collaborate to access/store
the usage data. Data handlers are in charge of keeping separated the current
changes and stored changes; this means that whenever Trackers acquires that
data should be updated a relevant handler is called.
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Figure 2.15: Tracker Classes

Handler units are then communicating with XML unit as it appears in Fig-
ure 2.13 to either access or store usage data. When storing information Event
objects will be merged, converted and serialized using an XML schema to be
exported into event logs. A depicted model to demonstrate how logs are con-
structed from XML writer is shown in Figures 2.16 and 2.17.

Figure 2.16: Model of usage Data log

When accessing information from logs, the usage data are de-serialized and Data
objects are created and will be represented on rabbit user interface.
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Figure 2.17: Model of usage Data log

Throughout this section, the architecture of the plug-in at-hand was analyzed,
and the capabilities of the tool were detailed. Even thought that Rabbit Eclipse
seems like a promising tool and was selected as a base, the current version of
the plug-in does not yet enable process mining. In the next section 2.4 a closer
look to requirements for process mining is given.

2.4 Process Mining and Disco

Process mining is the bridge between model-based process analysis and data-
oriented analysis techniques such as machine learning and data mining. 4. Pro-
cess mining is remarkable because it automatically allows the identification and
visualization of processes. As supported by [RMLvdA14] and [Say14] process
mining can also be used for software development and testing process.

Section 2.4.1 gives an overview of the Process mining, describing its importance
as well as its application. The different types of process mining are mention and
also its application to software engineering is analyzed. Further, the section
2.4.2 investigates the process mining tool Disco. A short explanation of how
it works and which aspects can be used to derive analysis of collected data log
events are elaborated.

4https://www.coursera.org/learn/process-mining

https://www.coursera.org/learn/process-mining
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2.4.1 Overview of Process Mining

Process mining is a relatively new and emerging art of using a family of tech-
niques which automatically observe and identify trends, patterns and sequences
from collected event logs to understand and produce non-trivial useful insights
regarding processes.

Today, various information systems (f.x. healthcare systems, business,etc) gen-
erate multitudes of event data. This causes organizations to have a struggle with
understanding the collected events. Therefore, the desirability of improving ef-
ficiency of processes as well as availability of data enhanced the integration of
process mining with data science [vdAETUETN16]. Moreover, process mining
can be used for conformance of processes, identification of bottlenecks, and also
prediction of execution problems [Rud15].

There are three main types of process mining 5 :

• Discovery: where the tool receives as input an event log and produces a
process model (Petri net) explaining the behavior of the recorded log.

• Conformance: where the tool receives an input an existing process model
with an event log of the same process and produces a comparison revealing
whether the event log conforms the process model.

• Enhancement: where the tool receives as input an existing process model
and an event log with the actual process recorded and produces an im-
proved or extended model.

Researchers in [RMLvdA14] and [Say14] proved that process mining can be
used for software development. According to this, the decision to apply process
mining was taken and the most suitable type is discovery since this project aims
to discover and understand the workflow of a developer within an IDE.

Since process mining is a cutting edge technology, several process mining tools
were invented for example most common are ProM [vDAV+05], Disco 6, Celonis
7.

Disco tool was proposed by the supervisors and used throughout this thesis, in
the next section 2.4.2 a further description on how the tool works is provided.

5https://www.coursera.org/learn/process-mining
6https://fluxicon.com/disco/
7https://www.celonis.com/?gclid=EAIaIQobChMI2fWo3fan2QIVFyjTCh17xQ_

vEAAYASAAEgK5q_D_BwE

https://www.coursera.org/learn/process-mining
https://fluxicon.com/disco/
https://www.celonis.com/?gclid=EAIaIQobChMI2fWo3fan2QIVFyjTCh17xQ_vEAAYASAAEgK5q_D_BwE
https://www.celonis.com/?gclid=EAIaIQobChMI2fWo3fan2QIVFyjTCh17xQ_vEAAYASAAEgK5q_D_BwE
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2.4.2 Overview of Disco

Disco is a complete process mining toolkit that makes process mining rapid,
flexible and easy. Disco helps to process raw data provided in event logs using
visual maps, providing metrics and statistics, as well as filtering from activities
or paths. 8 Moreover, despite the fact that Disco offers graphical representa-
tion of the raw data, it also allows the creation of animation to visualize the
process at-hand with a video animating the process. The visualisation feature
is relatively helpful to identify bottlenecks of the process.

An overview of the most significant parts of Disco depicted from 9 follows, since
the knowledge behind how Disco operates was a crucial part for this thesis.

The first step to process mining is to organize the raw data sets which will be
used. Disco tool was designed to allow the user to import data easily. The tool
allows to open a CSV or Excel file with the raw data sets in a read-only format.
In figure 2.18 and 2.19 the 3 steps to follow when importing the raw data sets
are shown. Firstly, the selection of each column and secondly configuration of
each column according to what is representing is possible.

The configuration categories are defined as follows:

• case ID, which determines the scope of the process. Using that the process
mining tool can compare several execution of the process to one another,
it uniquely identifies a single execution of the process.

• activities, which determines the level of detail for the process steps. Using
that, each step of the process is described, some of these steps might occur
more than once for a single case.

• time-stamps, which determines when the activity took place. This is im-
portant to analyze timing behavior and also to provide a sequence between
the activities.

• additional attributes are defined as either resources or attributes and
they are optional. They are helpful to filter the analysis to become more
precise.

It is mandatory to have at least one case id, and for the activities and also a
time-stamp are prerequisites for the tool to be able to process mine the given

8https://fluxicon.com/disco/
9https://fluxicon.com/disco/files/Disco-User-Guide.pdf

https://fluxicon.com/disco/
https://fluxicon.com/disco/files/Disco-User-Guide.pdf
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Figure 2.18: Steps 1 and 2 required to insert raw data sets into disco

event logs. The third step is to import the data as shown in 2.19. Once the
event log is imported, an automatic process discovery mapping is provided by
Disco and graphical representation and other statistics are generated.

Figure 2.19: Step 3 required to insert raw data into disco

Furthermore, there are 6 different types of filters provided in Disco which are
highly helpful and allow the ease of interaction, filtration and inspection of the
event log( see Figure 2.20).

The time frame filter which enables to focus on apart of a log executed in a
certain period of time. Next is the variation filter which enables the filtering
either the most common or exceptional behavior in a process. The performance
filter which is filtering in relation to a specific set of performance criteria. These
performance criteria could be case duration, number of events, case utilization,
active time, or waiting time. Following is the end point filter which trims out
events that are not in the boundary of the beginning and finishing activity. Also
the attribute filter which allows the selection of events based on activity and
resources. Last but not least the followers filter which filters by sub-sequences.
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Figure 2.20: Available filtering from Disco

This filtering capability of Disco provides all the information required to anal-
yse more efficiently the process. While process discovery Disco offers automatic
process discovery by providing information regarding an activity for Frequency
and Performance as appeared in figure 2.21. Moreover, Disco allows the regula-
tion of how detailed the mapping solution should be by providing the option to
set the percentage of activities and paths to be shown.

Figure 2.21: Available filtering from Disco

Using this tool in a later stage of this thesis will provide understanding for
developers’ workflow.
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Chapter 3

Problem Definition

The purpose of this thesis is to capture data on how developers interact with
IDE while developing software and to mine developers’ work-flows from IDE
usage using process mining techniques.

To detect available and potential technology candidates that can offer recording
of developers activity within IDE, a research was carried out and is presented in
chapter 2. The selection of Eclipse IDE and Rabbit Eclipse as the tools at-hand
was made and the reasons behind this decision are analyzed in previous sections
2.2 and 2.3, respectively.

Although, the chosen technologies could provide broad and profound informa-
tion regarding developers’ interactions within Eclipse IDE, deriving any further
conclusions using process mining tool Disco regarding developers’ workflow was
rather inconvenient.

Therefore in order to pursue the purpose of this thesis, modifications on how the
selected tools operate were applied and also the perception of captured events
was changed. This means that the tools had to be modified from asking how
many times an interaction occurred or how long did it last, to ask:

1. when the interaction occurred
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2. which resource or resources were influenced during the interaction

Further, in order to enable process mining of the event logs, they are required
to have a case id and time-stamps, as mentioned in Section 2.4. In addition, to
provide process mining in a more abstract level, a classification of commands
was also a requirement.

Moreover, since Java events have been recorded before from Rabbit Eclipse, as
mentioned in Section 2.3.2, exploring the ability to process mine source code
was set as a secondary goal.

Figure 3.1 depicts a new use case diagram which highlights the modified and
added use cases required to enable process mining for Rabbit Eclipse.

Figure 3.1: Use case diagram showing new use cases (purple), modified uses
cases (green), and unchanged use cases (grey)

The modified use cases presented in the diagram are related to how data and
log events are captured by Rabbit Eclipse.

The use case Export usage data log files refers to the modifications made to
XML schema constructing event logs and the use case Organize usage data was
modified to record also when an interaction occurred, instead of only estimating
duration by merging and converting usage data.

The new use cases created are related to how interactions are interpreted by
Rabbit Eclipse. The use case Categorize Commands provides a classification for
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available command events. Further, the use case Analyze Commands serves the
purpose of identifying resources influenced by an interaction.

Lastly, Analyze Java elements use case identifies details in regards to recording
source code interactions.

These mentioned use cases are vital to the modifications made in the architecture
and components of Rabbit Eclipse and the design in regards to them is further
elucidated in the next chapter 4.
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Chapter 4

Design and Implementation

In this chapter the mandatory modifications for achieving the requirements de-
scribed in Chapter 3, are modeled and analyzed thoroughly.

The design derived to accommodate the requirements set is described through-
out the next sections. In the first Section 4.1 of this chapter, the design which
is required to enable process mining is described. Further, the next section 4.2
provides a model suggesting the correlation of command and file interactions.
Last but not least, the section 4.3 provides two design solutions which enable
process mining of source code.

To start with, Figure 4.1 represents the architecture of Rabbit Eclipse and high-
lights units which will be modified. In a first glance, the modified units are:
XML unit which is used during storage or accessing of event logs, Data and
Event units which contain information for interactions, and also Trackers which
are responsible to record developers’ interactions. On the other hand Handler
units and the Rabbit UI unit remain unchanged.
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Figure 4.1: Architecture of Rabbit - Eclipse plugin diagram showing modified
units (green) and unchanged units(grey)

4.1 Design for Process Mining

This section presents the modeling steps towards process mining. Firstly, at-
tention is given to model timing interactions in section 4.1.1, developers id in
section 4.1.2 and classification of commands in section 4.1.3.

4.1.1 Include Timing interactions

The first requirement is to gather timing information and more specifically to
obtain when a developer interacted with IDE.

Based on the previous version of Rabbit Eclipse plugin, elaborated in Section
2.3, interactions were collected and the total duration of an interaction was
calculated. XML units, were responsible to register one entry per interaction in
the event log with only the total duration of the interaction.

To approach this situation, Rabbit Eclipse plugin was modified. The modifica-
tion made was in accordance to XML units which were directed not to merge
the events but to generate and register new entry for every interaction that took



4.1 Design for Process Mining 37

place. As it is visible in Figure 4.2, the exported usage data logs have been en-
dorsed with fields addressing the time. A time-stamp of when an interaction was
started and also a time-stamp when an interaction was ended, (TS_START)
and (TS_END) respectively, were added. The time registered is standardized
to follow the SQL format time-stamp (YYYY - MM - DD HH:MM:SS).

Figure 4.2: Models of event logs

4.1.2 Include Developer’s id

A requirement to allow process mining, as mentioned in Section 2.4, is to have
a case id. In order to provide a case id, the addition of a field representing the
id to all entries in event logs exported by Rabbit Eclipse was mandatory and is
visible in Figure 4.2.

The case id was designed to enable two approaches for process mining. These
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approaches are (a) mining interaction of an individual developer over different
development stages such as implementing, debugging and testing and (b) mining
interaction of a developers group executing the same task.

To enable both, the refresh button which is visible on the interface of Rabbit
Eclipse was enhanced. In the first case, to allow process mining of different
development stages, the refresh button was designed so that when a developer
presses the button a new development stage would be identified, and therefore
the case id would increase to indicate the stage change. However, this provides
inaccuracies since, the judgment of changing the sessions is based on the human
factor.

On the other hand, to fulfill the second case the refresh button is not taken into
consideration and the software assigns a constant number in the field of case id.

4.1.3 Include Command categories

To accompany further process mining, as described in Chapter 3, an abstrac-
tion level of command interactions was required. Command interactions were
classified by following the origin categories contained in the book [Bur09]. In
relation to this Categorize Commands use case was realized.

The previous version of Rabbit Eclipse gathered origin category for every com-
mand interaction. However, it was not registered in the exported event logs,
mentioned in Section 2.3.2. To realize this the data structure along with the
related XML schema of Rabbit Eclipse, were modified to accommodate the re-
quired field to include category in command interaction logs.

4.2 Design for Locating command - resource in-
teraction

A significant requirement which was defined in Chapter 3 was to locate which
resource is influenced by a developer’s interaction within IDE.

The previous version of Rabbit Eclipse provided captivity of File events and
Command events by using File and Command tracker units, which were ana-
lyzed in Section 2.3.2. File tracker unit was responsible to capture the duration
of interaction with a file, whereas Command tracker unit was responsible to
explore metrics regarding the usage of commands. However the fact that both
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type of events were captured, the tool did not provide any correlation between
them. Therefore, this inconvenience limits the capabilities of the tool towards
process mining.

To resolve the limitation and pursue the requirement of locating which resource
was influenced by developers’ interaction, major changes have been made on
Command tracker unit to allow the combination of these two interaction types,
i,e. File and Command.

In order to combine these two interaction events, File and Command a sequence
of several steps were followed.

Step 1: command influence classification

To begin with, a list with available standard command interactions was obtained
from [Bur09]. Going through the list, as mentioned in Section 2.3.2, it revealed
all combinations of keyboard bindings and menu bindings which Rabbit Eclipse
can capture. Using this information the realization of what influence a captured
command interaction can have on different resources, i.e. files or projects, was
possible. Therefore, all commands could be characterized by their influence on
resources, and these are detailed in Appendix A.1.

This led the decision to distinguish between categories of command interactions.
These categories, demonstrated in Figure 4.3, are single resource influence which
refers to the influence a command has its only on a single file (f.x. copy, end
line) and group resource influence which refers to the influence a command has
on a project, or a group of files (f.x. move file, rename).

This procedure distinguished the categories regarding influence command in-
teractions have on resources, and therefore provided knowledge in how many
resources a command can influence. The next step to accomplish combination
of the File and Commands interactions is to determine the specific resources
that are influenced.



40 Design and Implementation

Figure 4.3: Examples of the two categories distinguished are single resource
influence and group resource influence

Step 2: influenced resource detection

In order to support the need of determining the specific resources which were
influenced by a command interaction, was to create a new tracker unit, specif-
ically focusing on resource changes(i,e, an addition, a removal or an edition).
This tracker unit was responsible for keeping track of when and which resources
have been changed.

In Figure 4.4 a behavioral state machine to describe the behavior for this unit
is depicted. The state machine is using the design patterns of a listener and
a visitor [SS03]. The listener is waiting until a command execution interaction
occurred which caused the change for resources. When the listener detects this
interaction then it collects a resource event and triggers a visitor. A visitor is
responsible to go through the resource event in order to determine what was the
type of change (addition, removal, edition) and most importantly to determine
the name of the resource influenced.

After the visitor processes the resource event, the relevant interaction informa-
tion captured which are the name of the resource influence, the type of change on
the resource and a time-stamp are stored. To accommodate this, a data struc-
ture to maintain the interaction is required was created following the Rabbit
Eclipse data structures, mentioned in Section 2.3.2.

The described procedure explains how the resource names which were influenced
by a command interaction are gathered.
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Figure 4.4: Behavioral state diagram, to show the relation between the listener
and the visitor

Step 3: Combination of command interaction and influenced resource

At last, in order to realize the combination of file and command interactions,
there are two aspects to be considered. These aspects are how a command
interaction is captured and how a command interaction is stored.

To start with, Figure 4.5 demonstrates the use case Analyze Command which
realizes the first aspect of how a command interaction will be captured.

In detail, once a command interaction is detected, the details(command name,
time stamp, etc.) for that interaction are gathered. Then, the command inter-
action is being processed to identify in which influence category it belongs to,
single or group resource influence. According to which influence category the
command belongs to, the influenced resources are captured. In case of group
resource influence, for each resource a new command interaction is registered,
otherwise only one new command interaction is registered.

Further, to realize the second aspect, of how a command interaction is registered,
data structure along with the related XML schemas of Rabbit Eclipse, mentioned
in Section 2.3.2, were modified to accommodate the required field to include file
name.

An example of a common command - file interaction entry is shown in Figure
4.6
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Figure 4.5: Activity diagram - Analyze Command describes the functionality
required to capture a command-file interaction

Figure 4.6: Command - file interaction entry
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4.3 Design for Analyzing Java element interac-
tions

As a secondary purpose of this thesis as mentioned in Chapter 3, the requirement
of analyzing Java element interactions was set to enable process mining of source
code.

Based on the previous version of Rabbit Eclipse plugin, elaborated in Section
2.3.2, java element interactions were recorded. Java Element interactions are
interactions on source code elements, (f.x a change of method signature or the
class). Although Rabbit Eclipse recorded information in regards to these inter-
actions, only an identifier and duration for each element was exported into the
event logs.

To undertake this situation, currently there are two methodologies that can be
followed.

4.3.1 Detecting Java element interaction - Design 1

The first methodology was to modify the data structure along with the related
XML schema of Rabbit Eclipse, to accommodate the additional required infor-
mation. The addressed additional information fields are shown in Figure 4.7.

The fields included are listed:

• JE_ID which is the handle identifier id

• FILE_NAME which is simply the name of the resource which contains
the element

• PARENT which resource is the parent of the current resource

• FILE_TYPE which indicates whether the resource is a class or an inter-
face (5 - class, 9 - interface)

• TS_START which indicates when this java element interaction started

• TS_END which indicates when this java element interaction finished

• DURATION for how long this element has been modified
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Figure 4.7: Java Element - Java interaction entry

4.3.2 Detecting Java element interaction - Design 2

The second methodology was to built another tracker responsible to retrieve
java element interactions through the Abstract Syntax Tree (AST) constructed
by Eclipse [SS03].

In order to do that several steps were followed. Firstly, the detection of when
a java element interaction occurred, and secondly to define information for the
interaction are required.

To start with, a java element interaction implies a change of source code element,
within a resource file. Therefore, to detect when a java element interaction
occurred, recording when a resource file was modified is sufficient. The design
from the previous Section 4.2 for detecting updated files is used.

In order to define information for the interaction, the AST is used. The AST
is a detailed tree representing the Java source code. For each project inside a
workspace the AST is able to recognize the java elements, as mentioned in the
book [SS03]

Further, the AST is updated when a resource file has been modified. The
structure of AST is demonstrated in Figure 4.8, and it suggests that to retrieve
information for a java element resource from AST, is required to iterate the tree.
By using the AST to retrieve information for java element interaction and the
resource file, the diagram represented in Figure 4.9 demonstrates the use case
Analyze Java Elements.
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Figure 4.8: AST example

In detail once a resource change is detected, timing information and resource
name are gathered for the java interaction. If the resource was added/removed
then identification of what was added/removed is done (file, folder) and these
events are registered. In case of an entire project deletion this branch of the dia-
gram will be executed several times. On the other hand, if the changed resource
was a type of java source code file then is further examined. An iteration of the
updated AST and the current methods of the java file at-hand are gathered.
Further, if the file was not previously modified, then the file at-hand is a new
entry. This means that all the methods detected from the previous stage need
to be stored and registered as new events. Otherwise, a comparison between the
newly retrieved methods and the stored methods for the file-at hand. Finally
the results from this comparison are registered as a new entry in the event log
for all methods added, removed or changed. Thereafter, the process awaits for
a next resource change.
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Figure 4.9: Activity Diagram: Analyze java elements

In addition the XML units had to be modified to accommodate this new type of
recording java element interactions. An additional data structure along with the
related schema for Rabbit Eclipse was created. In Figure4.10 shows the listed
fields:

• FUP_ID which is the full path to the corresponding resource file

• FILE_NAME which is simply the name of the resource

• FILE_TYPE which indicates whether the resource is a file, a folder, or a
project

• METHOD_NAME which is the name of the method

• METHOD_SIGN which is set as the signature of the method

• METHOD_TYPE which is set as the return type of the method
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• METHOD_ACT which identifies whether the method was added, re-
moved, or edited.

• TS_START which indicates when this java element interaction occurred

Figure 4.10: Fileupd - java interaction entry

4.3.3 Comparison of Design 1 and Design 2

To sum up, both designs mentioned in Section 4.3.1 and in Section 4.3.2 have
been implemented to enhance the secondary requirement this thesis, which was
to enable process mining of source code.

To pursue this, the exported event logs where built to server the minimum
requirements for process mining, case ID, activity and time-stamp as referenced
in Section 2.4.

The exported java and fileupd event logs are similar, and serve the same purpose
of tracking a java element interaction. However, there are two fundamentals
differences. The first difference is that Design 1 provides a compact version of
the java interaction, whereas Design 2 is more detailed and provides gathered
method information (i,e. sign, type, name, action). The other difference is that
Design 1 provides a starting time-stamp and ending time-stamp whereas Design
2 only provides a starting time-stamp.

Even though, both of the designs could be used to provide process mining for
java element interactions.
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Chapter 5

Process Mining Analysis

As discussed before in Section 2.4, process mining is an evolutionary technique
which can also be used to provide valuable knowledge for software engineering
[RMLvdA14] and [Say14]. This Chapter is dedicated to apply process mining on
the recorded event logs from the new implemented version of Rabbit Eclipse. The
attempt to reveal that process mining developers’ through interactions within
Eclipse IDE is possible is pursued by initiating an experiment. During this
experiment, Rabbit Eclipse was able to retrieve the event logs from participants
and enable process mining successfully.

In the first Section 5.1 of this Chapter the requirements to enable process min-
ing are analyzed. Further in Section 5.2, the approach followed to refine the
raw event logs retrieved from Rabbit Eclipse plugin is explained. Thereafter,
the refined event logs are imported into Disco and the derived conclusions are
presented in Section 5.3. Last but not least, Section 5.4 converse about the
overall results of this procedure.
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5.1 Disco Requirements Setup

To enable process mining using Disco, the selection among the three different
techniques analyzed in Section 2.4 was required. Among them the most suitable
was the discovery technique. This technique is used when only an event log is
available for input and produces a process model explaining the behavior of the
recorded log.

Further, Disco requires the event log to be provided in a CSV or EXCEL format
and also to contain at least a case ID, an activity, and a time-stamp as mentioned
in Section 2.4.

For this reason, the most promising event logs generated by the Rabbit Eclipse,
modeled in the previous Chapter 4, are shown in Figure 5.1. These event logs
were modeled and implemented to meet the requirements for Disco. These
logs precisely collect when (TS_START, TS_END) and where (FILENAME)
interactions have occurred. Further, to establish a case ID the events were
provided with an identifier (DEV_ID), where this identifier is used to distinguish
which developer invoked the interaction.

Figure 5.1: The event logs used for process mining

Since, the modified version of Rabbit Eclipse can successfully retrieve these
organized event logs, the decision to retrieve a larger data set was taken. An
experiment to reveal developers’ workflow was designed and a plan of action
was constructed to refine the raw event logs retrieved from the experiment. In
the following Section 5.2 the experiment and the plan of action are detailed.
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5.2 Mining Approach

In this section, the experiment to retrieve raw event logs from developers is de-
signed and the methodology to refine the data set retrieved from Rabbit Eclipse
is indicated. The steps required to be followed in order to design and materialize
the experiment are shown in 5.2.

Collect Data1

Prepare Data2

Combine Data3

Filter Data4

Figure 5.2: Process Mining approach

Step 1: Collect data

The first step in the approach is the collection of event logs to create a data
set. The current data set was derived from 6 participants who have an academic
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background. Most of the participants were familiar with Eclipse IDE, however,
their level of experience within Eclipse IDE differs.

Participants were assigned a specific task and were given guidelines to setup
the tool in their Eclipse IDE. In Appendix B, the task and the guidelines are
presented in detail. Participants had to import the plugin to their Eclipse first
and then follow the task. The task required the participant to create a small
project implementing an inheritance java example. A description as well as a
class diagram were provided, in order to clarify the task and to define names to
be used for classes and methods.

The reason behind requiring participants to follow the predefined naming is to
allow feasibility of process mining with regards to affected resources. Otherwise,
if participants were given the permission to use their own naming, then is highly
probable that a great variation between resources naming would be generated,
and therefore correlation of data would be hardly possible.

Step 2: Prepare data

Once the tool is established in Eclipse then it begins to capture interaction
events. This usually results the creation of noise events such as:

• data set information, (f.x. date see Figure 5.3), which is defined when a
developer restarts Eclipse. This information is recorded, but is not useful,
since the desired event log is required to only contain the fields defined
previously in Section 5.1.

• unrelated interactions, which are interactions with other projects existing
in the current workspace

• folder, project interactions (see Figure 5.4), which are out of the scope of
this analysis due to the nature of the assigned task.

Figure 5.3: Noise created by data set information
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Figure 5.4: Noise created by interactions with folders and projects

These noise events are removed manually from event logs. The last modification
to prepare the data set is to convert the exported XML format event logs to
CSV format. To make this possible a program which converts an XML file to a
CSV file was created.

At the end of this step, the noise have been removed and the XML logs have
been converted to CSV logs.

Step 3: Combine Data

The third step in the process as suggested in Figure 5.2 is to combine event logs
of the same type (Command logs, FileUpd logs, etc.). As a result one CSV file
for every type is created.

Step 4: Filter Data

The last step show in Figure 5.2, is to filter the data of CSV files. This means
that all entries generated which are invalid will be filtered out. An invalid entry
is an entry which either it has been wrongly named or it has been marked with
the filename field as invalid. A wrongly named entry is for example, when a
participant, instead of using correctly the requested naming "Test.java", used
"test.java". While the filename field is marked as invalid when the participant
begins to interact with Eclipse IDE without initially selecting a file.

Furthermore, one of the participants produced a considerable amount of in-
teractions compared to the others. Consequently, the choice to filter out this
participant’s event logs was taken.

Step 5: Disco

The final step is to access and shed more light into the data set which have been
captured and refined. The data set is imported to Disco process mine tool and
the results obtained are elaborated in Section 5.3.
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5.3 Results from Disco

Throughout this section, the refined event logs gathered as described in the pre-
vious Section 5.2 and are used to derive results for understanding of developers’
workflow within the environment of Eclipse. To do that, the refined event logs
are imported to Disco. As introduced in Section 4.1, the option for case-id, ac-
tivity, time-stamp, resource are defined and this enables the discovery process.
The derived disco diagrams are illustrated and discussed.

5.3.1 Result 1 - Most Commonly used Commands

The aim for this part is to reveal the most commonly used commands by devel-
opers.

To do that firstly, the command event log exported from Rabbit Eclipse was
imported to Disco. The selected options for the discovery process were: case-id
= developer id, activity = Command names, time-stamp = TS_START.
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40 32
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Undo

40

Save

82

Paste

32

Figure 5.5: The most commonly used commands.

Figure 5.5 shows that the most common commands used by participants, are
Save, Undo, Paste. Similarly, in a previous study [MKF06] which was related
to Java developers’ command usage within Eclipse, the most commonly used
commands were Save, Undo, Paste.

Secondly to investigate the commands further, the classification of commands
was exploited, in Section 4.1.3. The command event log was used to derive this
result. The selected options for the discovery process were: case-id = developer
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id, Activity = Categories, time-stamp = TS_START, Other Attributes = com-
mand names and Filenames. In Figure 5.6 the most commonly used categories
are demonstrated. These categories are Edit and Text-Editing which are related
to interactions of a developer within a java file.
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Figure 5.6: The most commonly used categories of commands.
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5.3.2 Result 2 - Developers workflow

This part focuses on presenting the developers workflow within Eclipse IDE.

To start with, there are different workflow techniques a developer can follow.
Two common workflow techniques for object oriented programming, addressed
in [DK03], are a top-down approach and a bottom up approach. In a top-down
approach, a developer begins with the main problem and then subdivides it
into sub-problems. Whereas, in a bottom-up approach, a developer begins with
sub-problems building up to the main problem. In relation to the assigned task,
Figure 5.7 displays the techniques.

In order to exploit these techniques, the command event log was used. The
selected options for the discovery process were: case-id = developer id, Activity
= File names, time-stamp = TS_START, Other Attributes = command names.

Figure 5.7: Class diagram related to bottom up and top down techniques for
the given task.

In Figure 5.8 the results generated from Disco are illustrated. Half of the partic-
ipants followed top down approach by selecting to begin with DessertItem.java
which was the superclass. The other half of the participants followed a bottom
up approach by selecting to begin implementation with Candy.java or Sun-
dae.java which inherit from the superclass DessertItem.java.

Moreover, from this figure 5.8 is also observable that Cookie.java is the file with
the most interactions in comparison to the IceCream.java file which had the
less interactions. This is due to the reason, that Cookie.java was slightly more
complicated that IceCream.java.
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Figure 5.8: The class files (Candy, Cookie, Sundae, DessertItem, IceCream)
which are requested to be created by the developer throughout the
given task

5.3.3 Result 3 - Compare Developers workflow between
two classes

With regards to the observation made in Section 5.3.2 for the amount of inter-
actions in Cookie.java and IceCream.java, an investigation was carried out on
these two files. Scope of this investigation is the comparison of how developers
treat files with different difficulty level.

To make this possible the command event log was imported to Disco. The
selected options for the discovery process were: case-id = developer id, activity
= Command names, time-stamp = TS_START and attributes = filename and
categories.

For Figure 5.9 a filter to keep only the interactions related to Cookie.java was
enabled and similarly for Figure 5.10 the filter was set to IceCream.java.

What is prominent in these Figures, 5.9 and 5.10, is the commands appeared
belong mainly to Edit and Text - Editing categories (see Appendix A.1). More
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Figure 5.9: The commands used during the implementation of Cookie.java

specifically, commands like Undo, Copy, Paste belong to Edit category and
commands like Line start, Line End, Previous word, Delete Line belong to Text
Editing category.

It is noteworthy that Cookie.java has more Edit commands than IceCream.java
whereas, IceCream.java has more Text-Editing commands than Cookie.java.
From these findings is shown that the developers’ workflow changes when dealing
with larger source files.

Another distinct observation drawn from Figure 5.9 is the implementation ap-
proaches for Cookie.java. One approach is, when participants used Edit com-
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Figure 5.10: The commands used during the implementation of IceCream.java

mands (Copy, Paste, Cut) and the other approach is when participants used
Text Editing and Source commands (Quick Menu, Content Assist, Generate
getters and setters). The variation of participants’ experience within Eclipse
IDE is highlighted by the variety of usage of commands participants chose while
implementing the task.
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5.3.4 Result 4 - Compare Developers workflow in a spe-
cific class

In this part developers’ workflow through the implementation of a specific class
is studied.

The java event log was imported to Disco and the selected options for the dis-
covery process were: case-id = developer id, activity = method name and file-
name, time-stamp = TS_START and attributes = action (f.x. added, removed,
changed as described in Section 4.3).

Figure 5.11: Methods and main body of Cookie.java related to bottom up and
top down techniques

The workflow techniques top down and bottom up, as mentioned before in
Section 5.3.2, also apply for java source code. An example is shown in Figure
5.11, to illustrate that top down approach means implementing the main body of
the class first and then implementing the methods in detail. Whereas, bottom
up approach, means implementing method by method the main body of the
class.

For Figure 5.12 a filter to keep only the interactions related to Cookie.java was
enabled and similarly for Figure 5.13 the filter was set to Sundae.java. These
figures clearly show the different approach developers had while implementing
these files.
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Figure 5.12: The java events interaction in regards to a specified class called
Cookie.java

5.4 Summary

Overall this experiment, Rabbit Eclipse was able to retrieve the event logs from
participants and enable process mining successfully.

An understanding of developers’ workflow throughout their interactions in Eclipse
IDE was accomplished by:

• Identifying the most commonly used commands and categories of com-
mands, (see result 1 in Section 5.3.1)

• Identifying the two object oriented programming techniques, top down
and bottom up (see result 2 in Section 5.3.2 and result 4 in Section 5.3.4)

• Identifying how developers’ workflow might diverse when building a small
or a large source code (see result 3 in Section 5.3.3)
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Figure 5.13: The java events interaction in regards to a specified class called
Sundae.java

Nevertheless, while inspecting the retrieved interactions, the realization that the
particular given task to developers was relatively small came through. The ca-
pabilities of the implemented version of Rabbit Eclipse to capture the influenced
files were not fully exploited, since the task did not require any high re-factoring,
or navigation.
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Conclusion

In this study, the approach towards mining developers’ workflow, throughout
their interactions within an IDE, was investigated. This topic was chosen due
to its considerable potentials and due to the fact that there was a notable room
for improvement. The methodology was structured in three main axes. Firstly,
the investigation, which contained the analysis and selection of potential tools,
suitable for the extraction developers’ interactions from IDE. Secondly, the de-
sign and implementation, which included the changes required for the enable-
ment of the collection of developers’ interactions within an IDE and process
mining. Thirdly, the process mining analysis, in which the implemented tool
was evaluated, by initiating an experiment with external users - developers, the
workflow of whom was revealed. Finally, conclusions were carried out examin-
ing to which extent the initial targets were accomplished and identifying future
improvements.

Throughout the conducted investigation, the most widely known IDEs were re-
viewed and the IDE with the most adjustable framework - Eclipse - was selected.
In more detail existing plug-ins provided by Eclipse were analyzed. In total 7
plug-ins capable to retrieve developers’ interaction were identified and com-
pared based on their capabilities and adaptability. With respect to this, Rabbit
Eclipse plugin was chosen to be further investigated for several reasons, most
important of which were its well-structured online provided source code includ-
ing its accuracy in recording developers’ interactions performed by a developer.
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Subsequently, the architecture of Rabbit Eclipse was overviewed thoroughly, in
order for its operation to be understood and its limitations to be detected. The
last part of the research contained the investigation of process mining technique
and what was required in order for it to be enabled.

Although, Rabbit Eclipse provided statistical results on developers’ interaction,
it did not enable process mining. Due to this limitation, two major modifica-
tions were required on its operation in order to accommodate process mining.
The first was the adjustment of the tool in order to record time-stamps, a case
id, and a classification. The second regarded the revision of tool’s perception
on developers’ interactions. In order for the latter to be achieved, it was essen-
tial that developers’ interaction were combined with the influenced resources.
Furthermore, a change of secondary importance was made in order to provide
process mining on source code. Finally, since the guidelines for implementing
the modifications and the faced challenges for Rabbit Eclipse were designed, the
implementation was realized.

After the implementation of the mentioned modifications, Rabbit Eclipse was
capable of recording the developers’ interactions with respect to process mining
requirements as desired. To realize this, an experiment was initiated in order
to prove the valid functionality of the tool. A data set was created, which
contained recorded developers’ interactions from six participants. This data set
was refined following a created by the author methodology in order to remove
noise and enable the application of process mining.

Ultimately, three significant derived results were analyzed and illustrated in
diagrams. The first one was the successful identification of the most commonly
used commands and categories. The second one was the identification of two
object oriented programming techniques, which are top down and bottom up.
The last one was the identification of how developers’ workflow might diverse
when implementing a small or a large source code. These results indicate that
finally it is possible to mine developers’ workflow from their interactions within
an IDE.

It is expected that this thesis work will inspire successors and encourage them
to conduct a further research towards mining developers’ workflow by means
of their interactions within an IDE. Being a promising, adaptable and easily
adjustable tool, Rabbit Eclipse can be utilized for further investigations with
regards to mining developers’ workflows.

It is proposed that a more elaborated research can be carried out in order to ex-
pose the full capabilities of the tool implemented during the thesis. Specifically,
an experiment that explores refactoring and correcting bugs via an unknown
code, could potentially reveal promising results in terms of the workflow.
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Another crucial feature embedded into the Rabbit Eclipse is the capability of
recording developers’ source code interactions. Hence, this feature enables an
onward investigation of the process mining source code.
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Appendix A

Appendix 1: Rabbit Eclipse

In this appendix, additional information regarding the Rabbit Eclipse are pre-
sented.

A.1 Commands

Throughout this appendix section, tables representing the available commands
are gathered. These tables are separated according to [Bur09] different cate-
gories. Each table contains 7 columns, command name, key binding, v, menu
binding, v and located. For each command, the key binding and menu binding
are retrieve from the book [Bur09]. Further these two columns are followed by
a column called V, which is indicating whether or not Rabbit Eclipse is capable
of capturing the information from the specified command. Last and most im-
portant the column Located defines on which files the command at-hand has an
effect when executed.



CMD	Name		 Key	Binding	 V	 Menu	Binding	 V	 Located	
Add	Bookmark	 	 -	 Edit->	add	bookmark	 +	 ON	FILE	

Add	Task	 	 -	 Edit->	add	task	 +	 ON	FILE	
Content	Assist	 ctrl+space	 +	 Edit->	content	assist	 +	 ON	FILE	

Context	Information	 ctrl+shift+space	 +	 Edit->	parameter	hints	 +	 ON	FILE	
Copy	 ctrl+c	|	ctrl+Insert	 +	 Edit->copy	 +	 ON	FILE	
Cut	 ctrl+x	|	shift+delete	 +	 Edit->cut	 +	 ON	FILE	

Delete	 Delete	 +	 Edit->Delete	 +	 ON	FILE	
Find	and	Replace	 Ctrl+F	 +	 Edit->Find/Replace	 +	 ON	FILE	

Find	Next	 ctrl+K	 +	 Edit->Find	Next	 +	 ON	FILE	
Find	Previous	 ctrl+shift+K	 +	 Edit->Find	Previous	 +	 ON	FILE	

Incremental	Find	 ctrl+J	 +	 Edit->	Incremental	Find	Next	 +	 ON	FILE	
Incremental	Find	

Reverse	
ctrl+shift+J	 +	 Edit->	Incremental	Find	Previous	 +	 ON	FILE	

Paste	 ctrl+V	|	shift+Insert	 +	 Edit->	Paste	 +	 ON	FILE	
Quick	Diff	Toggle	 ctrl+shift+Q	 +	 	 +	 ON	FILE	

Quick	Fix	 ctrl+1	 +	 Edit->Quick	Fix	 +	 ON	FILE	
Redo	 ctrl+Y	 +	 Edit->Redo	 +	 ON	FILE	

Restore	Last	
Selection	

alt+shift+down	 +	 Edit->Expand	Selection	To	->	
Restore	Last	Selection	

+	 ON	FILE	

Revert	Line	 	 -	 	 -	 	
Revert	to	Saved	 	 -	 File->Revert	 -	 	

Select	All	 ctrl+A	 +	 Edit->Select	All	 +	 ON	FILE	
Select	Enclosing	

Element	
alt+shift+up	 +	 Edit->Expand	Selection	To	->	

Enclosing	Element	
+	 ON	FILE	

Select	Next	Element	 alt+shift+right	 +	 Edit->Expand	Selection	To	->	Next	
Element	

+	 ON	FILE	

Select	Previous	
Element	

alt+shift+left	 +	 Edit->Expand	Selection	To	->	
Previous	Element	

+	 ON	FILE	

Shift	Left	 	 -	 Source->Shift	Left	 +	 ON	FILE	
Shift	Right	 	 -	 Source->Shift	Right	 +	 ON	FILE	

Show	Line	Numbers	 	 -	 	 -	 	
Show	Tooltip	
Description	

F2	 +	 Edit->Show	Tooltip	Description	 +	 ON	FILE	

Toggle	Insert	Mode	 ctrl+shift+insert	 +	 Edit->Smart	Insert	Mode	 +	 ON	FILE	
Undo	 ctrl+Z	 +	 Edit->Undo	 +	 ON	FILE	

Word	Completion	 alt+/	 +	 Edit->Word	Completion	 +	 ON	FILE	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Close	 ctrl+F4	|	ctrl+W	 +	 File->Close	 +	 NEXT	FILE	

Close	All	 ctrl+shift+F4	|	
ctrl+shift+W	

!	 File->Close	All	 !	 CLOSE	ALL	-	ERROR	

Exit	 	 -	 File->Exit	 +	 	

Export	 	 -	 File->Export	 +	 Active	file	but	may	
affect	another	file	

Import	 	 -	 File->Import	 +	 Active	file	but	may	
affect	another	file	

Move	 	 -	 File->Move	 +	 Active	file	but	may	
affect	another	file	

New	 ctrl+N	 +	 File->New->Other	 +	 Active	file	but	may	
affect	another	file	

New	Menu	 alt+shift+N	 +	 File->New	 +	 Active	file	but	may	
affect	another	file	

Open	File	 	 -	 File->Open	File	 +	 Active	file	but	may	
affect	another	file	

Open	Workspace	 	 -	 File->Switch	
Workspace	

+	 Active	file	but	may	
affect	another	file	

Print	 ctrl+P	 +	 File->Print	 +	 ON	FILE	

Properties	 alt+enter	 +	 File->Properties	 +	 ON	FILE	

Refresh	 F5	 +	 File->Refresh	 +	 ON	FILE	

Rename	 F2	 +	 File->Rename	 +	 Active	file	but	may	
affect	another	file	

Revert	 	 -	 File->Revert	 +	 Active	file	but	may	
affect	another	file	

Save	 ctrl+S	 +	 File->Save	 +	 Active	file	but	may	
affect	another	file	

Save	All	 ctrl+shift+S	 +	 File->Save	All	 +	 Active	file	but	may	
affect	another	file	

Save	As	 	 -	 File->Save	As	 +	 ON	FILE	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Back	 	 -	 Navigate	->	Goto	->	back	 +	 ON	PROJECT	

Backward	History	 alt+left	 +	 Navigate->Back	 +	 ON	FILE	

forward	 	 -	 Navigate	->Goto->Forward	 +	 ON	PROJECT	

Forward	History	 alt+right	 +	 Navigate->Forward	 +	 ON	FILE	

Go	Into	 	 -	 Navigate->Go	Into	 +	 ON	PROJECT	
	

Go	to	Line	 ctrl+l	 +	 Navigate->GotoLine	 +	 ON	FILE	

Go	to	matching	bracket	 ctrl+shift+P	 +	 Navigate->Goto->	Matching	
Bracket	

+	 ON	FILE	

Go	to	Next	member	 ctrl+shift+down	 +	 Navigate->	Goto	->	Next	
Member	

+	 ON	FILE	

Go	to	Package	 	 -	 Navigate->	Goto->Package	 +	 ON	PROJECT	
	

Go	to	Previous	member	 ctrl+shift+up	 +	 Navigate->Goto->Previous	
Member	

+	 ON	FILE	

Go	to	resource	 	 -	 Navigate->Goto->Resource	 +	 ON	PROJECT	
	

Go	to	Type	 	 -	 Navigate->Goto->Type	 +	 ON	PROJECT	

Next		 ctrl.	 +	 Navigate->Next	 +	 ON	FILE	

Open	external	Javadoc	 shift+f2	 +	 Navigate->Open	External	
jJvadoc	

-	 	

Open	Declaration	 f3	 +	 Navigate->Open	declaration	 +	 ON	FILE	

Open	cAll	Hierarchy	 ctrl+alt+h	 +	 	 -	 ON	FILE	

Last	edit	location	ctrl+Q	 	 -	 Navigate->Last	Edit	Location	 +	 ON	FILE	

Open	structure	 ctrl	f3	 +	 	 -	 Active	file	but	may	
affect	another	file	

Open	super	implementation	 	 -	 Navigate	->	Open	Super	
Implementation	

+	 Active	file	but	may	
affect	another	file	

Open	Type	 ctrl+shift+T	 +	 Navigate->Open	Type	 +	 ON	FILE	

Open	Type	Hierarchy	 f4	 +	 Navigate->Open	Type	Hierarchy	 +	 Active	file	but	may	
affect	another	file	

Open	Type	in	Hierarchy	 ctrl+shift+H	 +	 Navigate->Open	Type	in	
Hierarchy	

+	 Active	file	but	may	
affect	another	file	

Previous	 ctrl,	 +	 Navigate->Previous	 +	 ON	FILE	

Quick	Hierarchy	 ctrl+T	 +	 Navigate->Quick	Type	Hierarchy	 +	 ON	FILE	

Quick	OutLine	 ctrl+O	 +	 Navigate->Quick	Outline	 +	 ON	FILE	

Show	in	Menu	 alt+shift+w	 +	 Navigate->Show	In	 +	 Active	file	but	may	
affect	another	file	

Show	in	Package	 	 -	 Navigate->Show	In	->Package	
explorer	

+	 Active	file	but	may	
affect	another	file	

Up	 	 -	 Navigate->Goto->Up	one	level	 -	 	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

CSV	Reprository	Exploring	 	 -	 Window->Open	Perspective->Other	 +	 ON	FILE	

Debug	 	 -	 Window->Open	Perspective->Debug	 +	 ON	FILE	

Java	 	 -	 Window->Open	Perspective->Java	 +	 ON	FILE	

Java	Browsing	 	 -	 Window->Open	Perspective->Java	Browsing	 +	 ON	FILE	

Java	Type	Hierarchy	 	 -	 Window->Open	Perspective->Java	Type	Hierarchy	 +	 ON	FILE	

Team	Synchronizing	 	 -	 Window->Open	Perspective->Team	Synchronizing	 +	 ON	FILE	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Build	All	 ctrl+b	 +	 Project->Build	All	 +	 ON	PROJECT	

Build	Clean	 	 -	 Project->Clean	 +	 ON	PROJECT	

Build	Project	 	 -	 Project->Build	Project	 +	 ON	PROJECT	

Close	Project	 	 -	 Project->Close	Project	 +	 ON	PROJECT	
Generate	Javadoc	 	 -	 Project->Generate	Javadoc	 +	 ON	PROJECT	

Open	Project	 	 -	 Project->Open	Project	 +	 ON	PROJECT	
Properties	 	 -	 Project->Properties	 +	 ON	PROJECT	
reBuild	All	 	 -	 	 -	 	

reBuild	Project	 	 -	 	 -	 	

repeat	Working	Set	Build	 	 -	 	 -	 	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Add	Class	Load	Breakpoint	 	 -	 Run->Add	Class	Load	Breakpoint	 +	 ON	FILE	

Add	Java	Exception	Breakpoint	 	 -	 Run->Add	Java	Exception	Breakpoint	 +	 ON	FILE	

Debug	ant	Build	 alt+shift+d	|	q	 +	 Run->Debug	ant	Build	 +	 ON	FILE	

Debug	Eclipse	Application	 alt+shift+d	|	e	 +	 Run->Debug	Eclipse	Application	 +	 ON	FILE	
Debug	Java	applet	 alt+shift+d	|	a	 +	 Run->Debug	Java	applet	 +	 ON	FILE	

Debug	Java	Application	 alt+shift+d	|	j	 +	 Run->Debug	Java	Application	 +	 ON	FILE	

Debug	JUnit	Plug-in	Test	 alt+shift+d	|	p	 +	 Run->Debug	JUnit	Plug-in	Test	 +	 ON	FILE	

Debug	JUnit	Test	 alt+shift+d	|	t	 +	 Run->Debug	JUnit	Test	 +	 ON	FILE	

Debug	Last	launched	 F11	 +	 Run->Debug	Last	launched	 +	 ON	FILE	

Debug	SWT	Application	 alt+shift+d	|s	 +	 Run->Debug	SWT	Application	 +	 ON	FILE	

Debug	 	 -	 Run->Debug	 +	 ON	FILE	

Display	 alt+shift+d	 +	 Run->Display	 +	 ON	FILE	

EOF	 ctrl+z	 +	 console	view	only	 +	 ON	FILE	

Execute	 ctrl+u	 +	 Run->Execute	 +	 ON	FILE	

External	Tools	 	 -	 Run->External	Tools	 +	 ON	FILE	

Inspect	 ctrl+shift+i	 +	 Run->Inspect	 +	 ON	FILE	

Profile	Last	Launched	 	 -	 Run->Profile	Last	Launched	 +	 ON	FILE	

Profile	 	 -	 Run->Profile	 +	 ON	FILE	

Remove	All	Breakpoints	 	 -	 Run->Remove	All	Breakpoints	 +	 ON	FILE	

Resume	 F8	 +	 Run->Resume	 +	 ON	FILE	

Run	ant	Build	 alt+shift+x	|	q	 +	 Run->Run	ant	Build	 +	 ON	FILE	

Run	Eclipse	Application	 alt+shift+x	|	e	 +	 Run->Run	Eclipse	Application	 +	 ON	FILE	

Run	Java	applet	 alt+shift+x	|	a	 +	 Run->Run	Java	applet	 +	 ON	FILE	

Run	Java	Application	 alt+shift+x	|	j	 +	 Run->Run	Java	Application	 +	 ON	FILE	

Run	JUnit	Plug-in	Test	 alt+shift+x	|	p	 +	 Run->Run	JUnit	Plug-in	Test	 +	 ON	FILE	
Run	JUnit	Test	 alt+shift+x	|	t	 +	 Run->Run	JUnit	Test	 +	 ON	FILE	
Run	Last	launched	 ctrl+F11	 +	 Run->Run	Last	launched	 +	 ON	FILE	
Run	Last	launched	external	tool	 	 -	 Run->Run	Last	launched	external	tool	 +	 ON	FILE	

Run	SWT	Application	 alt+shift+x	 +	 Run->Run	SWT	Application	 +	 ON	FILE	

Run	to	Line	 ctrl+R	 +	 Run->Run	to	Line	 +	 ON	FILE	
Run	 	 -	 Run->Run	 +	 ON	FILE	
Skip	All	Breakpoints	 	 -	 Run->Skip	All	Breakpoints	 +	 ON	FILE	
Step	Into	 F5	 +	 Run->Step	Into	 +	 ON	FILE	
Step	Into	selection	 ctrl+F5	 +	 Run->Step	Into	selection	 +	 ON	FILE	

Step	Over	 F6	 +	 Run->Step	Over	 +	 ON	FILE	
Step	Return	 F7	 +	 Run->Step	Return	 +	 ON	FILE	
Suspend	 	 -	 Run->Suspend	 +	 ON	FILE	
Terminate	 	 -	 Run->Terminate	 +	 ON	FILE	
Terminate	and	Relaunch	 	 -	 Run->Terminate	and	Relaunch	 +	 ON	FILE	
Toggle	Line	Breakpoint	 ctrl+shift+b	 +	 Run->Toggle	Line	Breakpoint	 +	 ON	FILE	
Toggle	Method	Breakpoint	 	 -	 Run->Toggle	Method	Breakpoint	 +	 ON	FILE	
Toggle	Step	Filters	 shift+F5	 +	 Run->Toggle	Step	Filters	 +	 ON	FILE	
Toggle	watchpoint	 	 -	 Run->Toggle	watchpoint	 +	 ON	FILE	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Change	Method	Signature	 alt+shift+c	 +	 Refactor->Change	Method	
Signature	

+	 Active	file	but	may	
affect	another	file	

Convert	Anonymous	Class	to	
Nested	

	 -	 Refactor->Convert	Anonymous	
Class	to	Nested	

+	 ON	FILE	

Convert	Local	Variable	to	Field	 alt+shift+f	 +	 Refactor->Convert	Local	
Variable	to	Field	

+	 ON	FILE	

Encapsulate	Field	 	 -	 Refactor->Encapsulate	Field	 +	 ON	FILE	

Extract	Constant	 	 -	 Refactor->Extract	Constant	 +	 ON	FILE	

Extract	Interface	 	 -	 Refactor->Extract	Interface	 +	 ON	FILE	

Extract	Local	Variable	 alt+shift+l	 +	 Refactor->Extract	Local	Variable	 +	 ON	FILE	

Extract	Method	 alt+shift+m	 +	 Refactor->Extract	Method	 +	 ON	FILE	

Generalize	Type	 	 -	 Refactor->Generalize	Type	 +	 ON	FILE	

Infer	Generic	Type	Arguments	 	 -	 Refactor->Infer	Generic	Type	
Arguments	

+	 ON	FILE	

InLine	 alt+shift+i	 +	 Refactor->Inline	 +	 ON	FILE	

Introduce	Factory	 	 -	 Refactor->Introduce	Factory	 +	 ON	FILE	

Introduce	Parameter	 	 -	 Refactor->Introduce	Parameter	 +	 ON	FILE	

Move	Refactoring	 alt+shift+v	 +	 Refactor->Move	 +	 Active	file	and	affects	
other	files	

Move	Member	Type	to	New	
File	

	 -	 Refactor->Move	Member	Type	
to	New	File	

+	 Active	file	and	affects	
other	files	

Pull	Up	 	 -	 Refactor->Pull	Up	 +	 ON	FILE	

Push	Down	 	 -	 Refactor->Push	Down	 +	 ON	FILE	

Rename	 alt+shift+r	 +	 Refactor->Rename	 +	 Active	file	and	affects	
other	files	

Show	Refactor	Quick	Menu	 alt+shift+t	 +	 	 -	 	

Use	Supertype	where	possible	 	 -	 Refactor->Use	Supertype	where	
possible	

+	 	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Declaration	in	
Hierarchy	

	 -	 Search->Declaration	in	
Hierarchy	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Declaration	in	
Project	

	 -	 Search->Declaration	in	
Project	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Declaration	in	
Working	Set	

	 -	 Search->Declaration	in	
Working	Set	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Declaration	in	
Workspace	

	 -	 Search->Declaration	in	
Workspace	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

File	Search	 	 -	 Search->File	Search	 +	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Implementors	in	
Project	

	 -	 Search->Implementors	
in	Project	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Implementors	in	
Working	Set	

	 -	 Search->Implementors	
in	Working	Set	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Implementors	in	
Workspace	

ctrl+h	 +	 Search->Implementors	
in	Workspace	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Open	Search	
dialog	

	 -	 Search->Open	Search	
dialog	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Read	Access	
Hierarchy	

	 -	 Search->Read	Access	
Hierarchy	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Read	Access	in	
Project	

	 -	 Search->Read	Access	in	
Project	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Read	Access	in	
Working	Set	

	 -	 Search->Read	Access	in	
Working	Set	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Read	Access	in	
Workspace	

	 -	 Search->Read	Access	in	
Workspace	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

References	in	
Hierarchy	

	 -	 Search->References	in	
Hierarchy	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

References	in	
Project	

	 -	 Search->References	in	
Project	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

References	in	
Working	Set	

	 -	 Search->References	in	
Working	Set	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

References	in	
Workspace	

	 -	 Search->References	in	
Workspace	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Referring	Tests	 	 -	 Search->Referring	Tests	 +	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Search	All	
occurrences	in	
File	Identifier	

	 -	 Search->Search	All	
occurrences	in	File	

Identifier	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Search	All	
occurrences	in	
Throwing	
Exception	

	 -	 Search->Search	All	
occurrences	in	Throwing	

Exception	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Search	All	
occurrences	in	
Implementing	

Methods	

ctrl+shift+u	 +	 Search->Search	All	
occurrences	in	

Implementing	Methods	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Search	All	
occurrences	in	
File	Quick	Menu	

	 -	 Search->Search	All	
occurrences	in	File	Quick	

Menu	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Write	Access	in	
Hierarchy	

	 -	 Search->Write	Access	in	
Hierarchy	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Write	Access	in	
Project	

	 -	 Search->Write	Access	in	
Project	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Write	Access	in	
Working	Set	

	 -	 Search->Write	Access	in	
Working	Set	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

Write	Access	in	
Workspace	

	 -	 Search->Write	Access	in	
Workspace	

+	 ON	FILE	BUT	MIGHT	NAVIGATE	ELSE	

	



CMD	Name	 Key	Binding	 V	 Located	
Clear	Mark	 	 -	 NOT	CAPTURED	
Collapse	 ctrl+numpad_substract	 +	 ON	FILE	
Copy	Lines	 ctrl+alt+down	 -	 NOT	CAPTURED	
Cut	Line	 	 -	 NOT	CAPTURED	

Cut	to	Beginning	of	Line	 	 -	 NOT	CAPTURED	
Cut	to	End	of	Line	 	 -	 NOT	CAPTURED	

Delete	Line	 ctrl+D	 +	 ON	FILE	
Delete	Next	 Delete	 +	 ON	FILE	

Delete	Next	Word	 ctrl+Delete	 +	 ON	FILE	
Delete	Previous	 	 -	 NOT	CAPTURED	

Delete	Previous	Word	 ctrl+Backspace	 +	 ON	FILE	
Delete	to	Beginning	of	Line	 	 -	 NOT	CAPTURED	

Delete	to	End	of	Line	 ctrl+shift+Delete	 +	 ON	FILE	
Duplicate	Lines	 ctrl+alt+up	 +	 ON	FILE	

Expand	 ctrl+Numpad_add	 +	 ON	FILE	
Expand	All	 ctrl+numpad_multiply	 +	 ON	FILE	

Insert	Line	Above	Current	Line	 ctrl+shift+enter	 +	 ON	FILE	
Insert	Line	Below	Current	Line	 shift+enter	 +	 ON	FILE	

Line	Down	 Down	 +	 ON	FILE	
Line	End	 End	 +	 ON	FILE	
Line	Start	 Home	 +	 ON	FILE	
Line	Up	 Up	 +	 ON	FILE	

Move	Lines	Down	 alt+down	 +	 ON	FILE	
Move	Lines	Up	 alt+up	 +	 ON	FILE	
Next	Column	 	 -	 NOT	CAPTURED	
Next	Word	 ctrl+right	 +	 ON	FILE	
Page	Down	 Page	Down	 	 NOT	CAPTURED	
Page	Up	 Page	Up	 	 NOT	CAPTURED	

Previous	Column	 	 +	 ON	FILE	
Previous	Word	 ctrl+left	 +	 ON	FILE	
Scroll	Line	Down	 ctrl+Down	 	 NOT	CAPTURED	
Scroll	Line	Up	 ctrl+up	 	 NOT	CAPTURED	

Select	Line	Down	 shit+down	 	 NOT	CAPTURED	
Select	Line	End	 shift+end	 	 NOT	CAPTURED	
Select	Line	Start	 shift+home	 	 NOT	CAPTURED	
Select	Line	Up	 shift+up	 	 NOT	CAPTURED	

Select	Next	Column	 	 	 NOT	CAPTURED	
Select	Next	Word	 ctrl+shift+right	 +	 ON	FILE	
Select	Page	Down	 shift+Page	Down	 	 NOT	CAPTURED	
Select	Page	Up	 shift+Page	Up	 	 NOT	CAPTURED	

Select	Previous	Column	 	 	 NOT	CAPTURED	
Select	Previous	Word	 ctrl+shift+left	 +	 ON	FILE	

Select	Text	End	 ctrl+shift+End	 +	 ON	FILE	
Select	Text	Start	 ctrl+shift+home	 +	 ON	FILE	

Select	Window	End	 	 	 NOT	CAPTURED	
Select	Window	Start	 	 	 NOT	CAPTURED	

Set	Mark	 	 	 NOT	CAPTURED	
Swap	Mark	 	 	 NOT	CAPTURED	
Text	End	 ctrl+End	 +	 ON	FILE	
Text	Start	 ctrl+home	 +	 ON	FILE	

To	Lower	Case	 ctrl+shift+Y	 +	 ON	FILE	
To	Upper	Case	 ctrl+shift+X	 +	 ON	FILE	
Toggle	Folding	 ctrl+numpad_divide	 +	 ON	FILE	

Toggle	Overwrite	 Insert	 +	 ON	FILE	
Window	End	 	 -	 NOT	CAPTURED	
Window	Start	 	 -	 NOT	CAPTURED	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Ant	 	 -	 Window->Show	View->Ant	 +	 ON	FILE	

Breakpoints	 alt+shift+Q,B	 +	 Window->Show	View->Breakpoints	 +	 ON	FILE	

Cheat	Sheets	 alt+shift+Q,H	 +	 Window->Show	View->Other->Cheat	Sheets	 +	 ON	FILE	

Classic	Search	 	 -	 Window->Show	View->	Other->Basic->Classic	
Search	

+	 ON	FILE	

Console	 alt+shift+Q,C	 +	 Window->Show	View->Console	 +	 ON	FILE	

CVS	Annotate	 	 -	 Window->Show	View->Other->CVS	Annotate	 +	 ON	FILE	

CVS	Editors	 	 -	 Window->Show	View->Other->CVS	Editors	 +	 ON	FILE	

CVS	Repositories	 	 -	 Window->Show	View->Other->CVS	Repositories	 +	 ON	FILE	

CVS	Resource	History	 	 -	 Window->Show	View->Other->CVS	Resource	
History	

+	 ON	FILE	

Debug	 	 -	 Window->Show	View->Debug	 +	 ON	FILE	
Display	 	 -	 Window->Show	View->Display	 +	 ON	FILE	
Error	Log	 	 -	 Window->Show	View->Error	Log	 +	 ON	FILE	
Expressions	 	 -	 Window->Show	View->Expressions	 +	 ON	FILE	

Java	Call	Hierarchy	 	 -	 Window->Show	View->Other->	Java->	Call	
Hierarchy	

+	 ON	FILE	

Java	Declaration	 alt+shift+Q,D	 +	 Window->Show	View->Java	Declaration	 +	 ON	FILE	

Java	Members	 	 -	 Window->Show	View->Other->Java	Browsing-
>Members	

+	 ON	FILE	

Java	Package	Explorer	 alt+shift+Q,P	 +	 Window->Show	View->Package	Explorer	 +	 ON	FILE	

Java	Packages	 	 -	 Window->Show	View->Other->Java	Browsing-
>Packages	

+	 ON	FILE	

Java	Projects	 	 -	 Window->Show	View->Other->Java	Browsing-
>Projects	

+	 ON	FILE	

Java	Type	Hierarchy	 alt+shift+Q,T	 +	 Window->Show	View->Type	Hierarchy	 +	 ON	FILE	

Java	Types	 	 -	 Window->Show	View->Other->Java	Browsing-
>Types	

+	 ON	FILE	

Javadoc	 alt+shift+Q,J	 +	 Window->Show	View->Javadoc	 +	 ON	FILE	

Junit	 	 -	 Window->Show	View->Other->Java->Junit	 +	 ON	FILE	

Memory	 	 -	 Window->Show	View->Other->Debug->Memory	 +	 ON	FILE	

Outline	 alt+shift+Q,O	 +	 Window->Show	View->Outline	 +	 ON	FILE	

Plug-in	Dependencies	 	 -	 Window->Show	View->Other->PDE->Plug-in	
Dependencies	

+	 ON	FILE	

Plug-in	Registry	 	 -	 Window->Show	View->Other->PDE	Runtime-
>Registry	

+	 ON	FILE	

Plug-ins	 	 -	 Window->Show	View->Other->PDE->Plug-ins	 +	 ON	FILE	

Problems	 alt+shift+Q,X	 +	 Window->Show	View->Problems	 +	 ON	FILE	

Registers	 	 -	 Window->Show	View->Other->Debug->Registers	 +	 ON	FILE	

Search	 alt+shift+Q,S	 +	 Window->Show	View->Search	 +	 ON	FILE	

Synchronize	 alt+shift+Q,Y	 +	 Window->Show	View->Other->Team-
>Synchronize	

+	 ON	FILE	

Variables	 alt+shift+Q,V	 +	 Window->Show	View->Variables	 +	 ON	FILE	

	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Active	Editor	 F12	 +	 Window->Navigation->Active	Editor	 +	 ON	FILE	

Close	All	Perspectives	 	 -	 Window->Close	All	Perspectives	 +	 ON	FILE	

Close	Perspective	 	 -	 Window->Close	Perspective	 +	 ON	FILE	

Customize	Perspective	 	 -	 Window->Customize	Perspective	 +	 ON	FILE	

Hide	Editors	 	 -	 	 	 	

Lock	the	Toolbars	 	 -	 	 	 	

Maximize	Active	View	or	
Editor	

ctrl+M	 +	 Window->Navigation->Maximize	Active	View	or	
Editor	

+	 ON	FILE	

Minimize	Active	View	or	
Editor	

	 -	 Window->Navigation->Minimize	Active	View	or	
Editor	

+	 ON	FILE	

New	Editor	 	 -	 Window->New	Editor	 +	 ON	FILE	

New	Window	 	 -	 Window->New	Window	 +	 ON	FILE	

Next	Editor	 ctrl+F6	 +	 Window->Navigation->Next	Editor	 +	 ON	FILE	

Next	Perspective	 ctrl+F8	 +	 Window->Navigation->Next	Perspective	 +	 ON	FILE	

Next	View	 ctrl+F7	 +	 Window->Navigation->Next	View	 +	 ON	FILE	

Open	Editor	Drop	Down	 ctrl+E	 +	 Window->Navigation->Switch	to	Editor	 +	 ON	FILE	

Pin	Editor	 	 -	 	 	 	

Preferences	 	 -	 Window->Preferences	 +	 ON	FILE	

Previous	Editor	 ctrl+shift+F6	 +	 Window->Navigation->Previous	Editor	 +	 ON	FILE	

Previous	Perspectivve	 ctrl+shift+F8	 +	 Window->Navigation->Previous	Perspectivve	 +	 ON	FILE	

Previous	View	 ctrl+shift+F7	 +	 Window->Navigation->Previous	View	 +	 ON	FILE	

Reset	Perspective	 	 -	 Window->Reset	Perspective	 +	 ON	FILE	

Save	Perspective	As	 	 -	 Window->Save	Perspective	As	 +	 ON	FILE	

Show	Key	Assist	 ctrl+shift+L	 +	 Help->Show	Key	Assist	 	 	

Show	Ruler	Context	Menu	 ctrl+F10	 +	 	 	 	

Show	Selected	Element	Only	 	 	 	 	 	

Show	System	Menu	 alt+-	 +	 Window->Navigation->Show	System	Menu	 	 	

Show	View	Menu	 ctrl+F10	 +	 Window->Navigation->Show	View	Menu	 	 	

Switch	to	Editor	 ctrl+shift+E	 +	 Window->Navigation->Switch	to	Editor	 	 	

	



CMD	Name	 Key	Binding	 V	 Menu	Binding	 V	 Located	

Add	Block	Comment	 ctrl+shift+/	 +	 Source->Add	Block	Comment	 +	 ON	FILE	

Add	Constructors	from	Superclass	 	 -	 Source->Add	Constructors	from	Superclass	 +	 ON	FILE	

Add	Import	 ctrl+shift+M	 +	 Source->Add	Import	 +	 ON	FILE	

Add	Javadoc	Comment	 alt+shift+J	 +	 Source->Add	Comment	 +	 ON	FILE	

Comment	 	 -	 	 -	 ON	FILE	

Externalize	Strings	 	 -	 Source->Externalize	Strings	 +	 ON	FILE	

Find	Strings	to	Externalize	 	 -	 Source->Find	Strings	to	Externalize	 +	 ON	FILE	

Format	 ctrl+shift+F	 +	 Source->Format	 +	 ON	FILE	

Format	Element	 	 -	 Source->Format	Element	 +	 ON	FILE	

Generate	Constructor	using	Fields	 	 -	 Source->Generate	Constructor	using	Fields	 +	 ON	FILE	

Generate	Delegate	Methods	 	 -	 Source->Generate	Delegate	Methods	 +	 ON	FILE	

Generate	Getters	and	Setters	 	 -	 Source->Generate	Getters	and	Setters	 +	 ON	FILE	

Indent	Line	 	 -	 Source->Correnct	Indentation	 +	 ON	FILE	

Organize	Imports	 ctrl+shift+O	 +	 Source->Organize	Imports	 +	 ON	FILE	

Override/Implement	Methods	 	 -	 Source->Override/Implement	Methods	 +	 ON	FILE	

Quick	Assist	-	Assign	parameter	to	
field	

	 -	 	 -	 NOT	
CAPTURED	

Quick	Assist	-	Assign	to	field	 ctrl+2,F	 -	 	 -	 NOT	
CAPTURED	

Quick	Assist	-	Assign	to	local	
variable	

ctrl+2,L	 -	 	 -	 NOT	
CAPTURED	

Quick	Assist	-	Rename	in	file	 ctrl+2,R	 -	 	 -	 NOT	
CAPTURED	

Quick	Assist	-	Replace	statement	
with	block	

	 -	 	 -	 NOT	
CAPTURED	

Quick	Fix	-	Add	cast	 	 -	 	 -	 NOT	
CAPTURED	

Quick	Fix	-	Add	import	 	 -	 	 -	 NOT	
CAPTURED	

Quick	Fix	-	Add	non	-NLS	tag	 	 -	 	 -	 NOT	
CAPTURED	

Quick	Fix	-	Add	throws	declaration	 	 -	 	 -	 NOT	
CAPTURED	

Quick	Fix	Change	to	static	access	 	 -	 	 -	 NOT	
CAPTURED	

Quick	Fix	Quality	field	access	 	 -	 	 -	 NOT	
CAPTURED	

Remove	Block	Comment	 ctrl+shift+/	 +	 Source->Remove	Block	Comment	 +	 ON	FILE	

Remove	Occurrence	Annotations	 alt+shift+U	 +	 	 -	 ON	FILE	

Show	Source	Quick	Menu	 	 -	 	 -	 NOT	
CAPTURED	

Sort	Members	 	 -	 Source->Sort	Members	 +	 ON	FILE	

Surround	with	try/catch	Block	 	 -	 Source->Surround	with	try/catch	Block	 +	 ON	FILE	

Toggle	Comment	 ctrl+/	
|ctrl+7|ctrl+shift+C	

+	 Source->Toggle	Comment	 +	 ON	FILE	

Toggle	Mark	Occurrences	 alt+shift+O	 +	 	 +	 ON	FILE	

Uncomment	 	 -	 	 -	 NOT	
CAPTURED	



	



Appendix B

Appendix 2

This appendix includes the experiment applied for process mining: the given
installation guide, the given guidelines, and the main class for their task and
also it includes the diagrams produced by the process mining tool.

B.1 Experiment

Instalation guide

This text contains installation instructions. After the installation, start Eclipse
and you will see a new view (named Rabbit) under the "Rabbit" category in
the show views dialog in Eclipse. A folder also named Rabbit will appear under
your home folder, it’s used as the XML database, it’s important that you don’t
modify files under this directory.

=== System Requirements: === * Eclipse 3.4, 3.5, or higher * JavaSE 1.6 or
higher * Mac, Linux, or Windows

=== Windows, Linux, Mac: === To install, unzip the zip file, then move the
two jar files into the *dropins* (or *plugins*) folder under your Eclipse’s folder,
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you may create the *dropins* folder if it’s not already created.

Note: The plug-in will not be loaded if the Eclipse is placed under a system
folder, for example, the "Program Files" directory under Windows Vista/7, the
simplest way to fix this is to move your Eclipse to another location such as your
home user folder, or see the alternative below.

=== Linux Alternative: === If you’ve installed Eclipse through the command
line (such as _"sudo apt-get install eclipse"_ on Ubuntu), then you can install
the plug-in by moving the two jar files into: /.eclipse/_-your-current-version-
_/dropins (or *plugins*).



The	purpose	of	this	short	experiment	is	to	gather	data	with	regards	to	Developers'	workflow	in	the	
Eclipse	IDE.	Therefore,	please	follow	the	task	carefully	and	develop	the	required	units.	It	is	
important	to	follow	the	given	steps	to	setup	the	environment	properly.	It	is	crucial	to	follow	the	
given	naming	for	your	variables	methods	and	classes.	
	
	
Step	1	:	Download		

	
• Download	the	jar	files	provided	on	the	google	drive.	
• Follow	InstallationGuide.txt	

	
• Create	a	new	workspace	inside	folder	“Test”		

	
	

	
Figure	1:	Create	Workspace	“Test”	

	
	
Step	2:	The	main	task	
	
At	this	point	you	are	ready	to	start.	The	tool	is	represented	in	the	Figure	2.	You	can	see	
information	regarding	the	different	activities	being	recorded	if	you	press	button	refresh	on	the	
tool.	Keep	in	mind	that	is	highly	important	to	follow	the	naming	notations	provided.		
To	obtain	valid	results	is	expected	that	you	follow	(see	Figure	3)	
	
	

	
	

Figure	2:	Rabbit	Eclipse	tool	



	
	

	
	

Figure	3:	Class	Diagram	
	
	
Create	a	project	named	Test.	To	activate	and	see	the	results	of	your	programming	session	Follow	
the	steps	in	Figure	4.	

	
	
	
	
	
	
	
	
	
	
	
	

	
Figure	4:	Activate	Rabbit	

	
	
	
	
	
	



The	task	is	fairly	simple,	the	purpose	is	the	implementation	of	inheritance	hierarchy	of	classes	
derive	from	an	abstract	superclass.		
DessertShop	class	is	given	to	you	and	contains	the	main	functions	of	the	shop	and	the	test	for	
your	classes.	Further	your	task	is	to	implement:	
	

1. DessertItem	abstract	superclass.		
2. Candy,	Cookie,	IceCream	classes	which	derive	from	DessertItem	superclass	
3. Sundae	class	which	derives	from	IceCream	class	

	
The	Candy	class	should	be	derived	from	the	DessertItem	class.	A	Candy	item	has	a	weight	and	a	
price	per	pound	which	are	used	to	determine	its	cost.	The	cost	should	be	calculated	as	(cost)	*	
(price	per	pound).		
	
The	Cookie	class	should	be	derived	from	the	DessertItem	class.	A	Cookie	item	has	a	number	and	a	
price	per	dozen	which	are	used	to	determine	its	cost.	The	cost	should	be	calculated	as	(cost)	*	
(price	per	dozen).	
	
The	IceCream	class	should	be	derived	from	the	DessertItem	class.	An	IceCream	item	simply	has	a	
cost.	
	
The	Sundae	class	should	be	derived	from	the	IceCream	class.	The	cost	of	a	Sundae	is	the	cost	of	
the	IceCream	plus	the	cost	of	the	topping.	
	
	
Step	4:	Extracting	Data	
	
Your	last	step	before	finishing	is	to	press	the	button	refresh.		
The	Plugin	has	now	recorded	your	activity.	The	documents	created	can	be	found	in	Rabbit	folders.	
For	both	mac	and	windows	users,	the	data	files	will	be	found	in	/Users/<UserName>/Rabbit/<.	
Users.	<username>.	runtime-New_configuration>.	
	
Mac	users	might	not	be	able	to	see	these	documents	because	they	are	considered	as	hidden	files,	
therefore	you'll	need	to	enable	hidden	files.	
	
Please	zip	all	the	files	created	and	send	them	to	s150954@student.dtu.dk	
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The main file given to developers was Dessertshop.java

1

2 pub l i c c l a s s DessertShop {
3 pr i va t e DessertItem [ ] myDessertItems ;
4 pr i va t e i n t numberOfItems ;
5 pr i va t e f i n a l i n t RECEIPT_WIDTH = 30 ;
6

7 pub l i c DessertShop ( ) {
8 myDessertItems = new DessertItem [ 1 0 0 ] ;
9 numberOfItems = 0 ;

10 }
11

12 pub l i c i n t numberOfItems ( ) {
13 r e turn numberOfItems ;
14 }
15

16 pub l i c void enterItem ( DessertItem item ) {
17 t h i s . myDessertItems [ numberOfItems ] = item ;
18 numberOfItems++;
19 }
20

21 pub l i c void c l e a r ( ) {
22 f o r ( i n t i = 0 ; i < numberOfItems ; i++)
23 t h i s . myDessertItems [ i ] = nu l l ;
24 numberOfItems = 0 ;
25 }
26

27 pub l i c i n t to ta lCos t ( ) {
28 i n t sum = 0 ;
29 f o r ( i n t i = 0 ; i < numberOfItems ; i++)
30 sum += myDessertItems [ i ] . getCost ( ) ;
31 r e turn sum ;
32 }
33

34 pub l i c f i n a l s t a t i c double TAX_RATE = 6 . 5 ; // 6.5%
35 pub l i c f i n a l s t a t i c i n t COST_WIDTH = 6 ;
36

37 pub l i c S t r ing cents2do l larsAndCents ( i n t cent s ) {
38 St r ing s = "" ;
39

40 i f ( c ent s < 0) {
41 s += "−";
42 cent s ∗= −1;
43 }
44

45 i n t d o l l a r s = cent s / 100 ;
46 cent s = cent s % 100 ;
47

48 i f ( d o l l a r s > 0)
49 s += do l l a r s ;
50

51 s += " . " ;
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52

53 i f ( c ent s < 10)
54 s += "0" ;
55

56 s += cent s ;
57

58 r e turn s ;
59 }
60

61 pub l i c i n t totalTax ( ) {
62 r e turn ( i n t )Math . round ( t h i s . t o ta lCos t ( ) ∗TAX_RATE / 100 .00) ;
63 }
64

65 pub l i c S t r ing toS t r i ng ( ) {
66 St r ing s = "" ; // r e c e i p t
67

68

69 s += " " + " De r l i c i o u s ! ! ! "+ "\n " ;
70 s += " " + "−−−−−−−−−−−−−−−−−−−−" + "\n " ;
71

72 f o r ( i n t j = 0 ; j < numberOfItems ; j++){
73

74 St r ing l = myDessertItems [ j ] . getName ( ) ; // items o f every
l i n e

75

76 // St r ing item = myDessertItems [ j ] . g e tC la s s ( ) . t oS t r i ng ( ) .
s ub s t r i ng (6 ) ; // get the item category

77

78 St r ing p = cents2do l larsAndCents ( myDessertItems [ j ] . getCost ( ) )
; // p r i c e o f every item

79 i f (p . l ength ( ) > COST_WIDTH) // v e r i f y the p r i c e i s with in
l ength

80 p = p . sub s t r i ng (0 , COST_WIDTH) ;
81

82 i f ( myDessertItems [ j ] i n s t an c e o f IceCream ) { // p r in t i f
i c e cream

83 whi le ( l . l ength ( ) < RECEIPT_WIDTH − p . l ength ( ) ) {
84 l += " " ;
85 }
86 s += l + p + "\n " ;
87 }
88 e l s e i f ( myDessertItems [ j ] i n s t an c e o f Sundae ) { // p r i n t i f

Sundae
89

90 s += ( ( Sundae ) myDessertItems [ j ] ) . getTopping ( ) + " Sundae
with\n " ;

91

92 whi le ( l . l ength ( ) < RECEIPT_WIDTH − p . l ength ( ) ) {
93 l += " " ;
94 }
95 s += l + p + "\n " ;
96 }
97 e l s e i f ( myDessertItems [ j ] i n s t an c e o f Candy) { // p r in t i f

Candy
98 s += ( (Candy) myDessertItems [ j ] ) . getWeight ( ) + " lb s @ " +
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99 cents2do l larsAndCents ( ( ( Candy) myDessertItems [ j ] ) .
getPricePerPound ( ) ) + " / lb . \ n " ;

100

101 whi le ( l . l ength ( ) < RECEIPT_WIDTH − p . l ength ( ) ) {
102 l += " " ;
103 }
104 s += l + p + "\n " ;
105 }
106 e l s e { // p r i n t i f Cookie
107 s += ( ( Cookie ) myDessertItems [ j ] ) . getNumber ( ) + " @ " +
108 cents2do l larsAndCents ( ( ( Cookie ) myDessertItems [ j ] ) .

getPricePerDozen ( ) ) + " /dz\n " ;
109

110 whi le ( l . l ength ( ) < RECEIPT_WIDTH − p . l ength ( ) ) {
111 l += " " ;
112 }
113 s += l + p + "\n " ;
114 }
115 }
116

117 St r ing l i n e = "\nTax " ;
118 St r ing tax = cents2do l larsAndCents ( t h i s . tota lTax ( ) ) ; // p r i n t

tax
119 whi le ( l i n e . l ength ( ) <= RECEIPT_WIDTH − tax . l ength ( ) )
120 l i n e += " " ;
121 s += l i n e + tax ;
122

123 St r ing to ta lCos t = cents2do l larsAndCents ( t h i s . t o ta lCos t ( ) +
th i s . tota lTax ( ) ) ; // p r i n t t o t a l co s t

124 l i n e = "\nTotal Cost " ;
125 whi le ( l i n e . l ength ( ) <= RECEIPT_WIDTH − t o ta lCos t . l ength ( ) )
126 l i n e += " " ;
127 s += l i n e + to ta lCos t ;
128

129 r e turn s ;
130 }
131 pub l i c s t a t i c void main ( St r ing [ ] a rgs ) {
132

133 DessertShop checkout = new DessertShop ( ) ;
134

135 checkout . enterItem (new Candy(" Peanut Butter Fudge " , 2 . 25 ,
399) ) ;

136 checkout . enterItem (new IceCream (" Van i l l a I c e Cream" ,105) ) ;
137 checkout . enterItem (new Sundae ("Choc . Chip I c e Cream" ,145 , "

Hot Fudge " , 50) ) ;
138 checkout . enterItem (new Cookie ("Oatmeal Ra i s in Cookies " , 4 ,

399) ) ;
139

140 System . out . p r i n t l n ("\nNumber o f i tems : " + checkout .
numberOfItems ( ) + "\n") ;

141 System . out . p r i n t l n ("\ nTotal co s t : " + checkout . t o ta lCos t ( )
+ "\n") ;

142 System . out . p r i n t l n ("\ nTotal tax : " + checkout . totalTax ( ) +
"\n") ;

143 System . out . p r i n t l n ("\ nCost + Tax : " + ( checkout . t o ta lCos t ( )
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+ checkout . tota lTax ( ) ) + "\n") ;
144 System . out . p r i n t l n ( checkout ) ;
145

146 checkout . c l e a r ( ) ;
147

148 checkout . enterItem (new IceCream (" Strawberry I c e Cream" ,145)
) ;

149 checkout . enterItem (new Sundae (" Van i l l a I c e Cream" ,105 , "
Caramel " , 50) ) ;

150 checkout . enterItem (new Candy("Gummy Worms" , 1 . 33 , 89) ) ;
151 checkout . enterItem (new Cookie (" Chocolate Chip Cookies " , 4 ,

399) ) ;
152 checkout . enterItem (new Candy(" Sa l t Water Taffy " , 1 . 5 , 209) )

;
153 checkout . enterItem (new Candy("Candy Corn " , 3 . 0 , 109) ) ;
154

155 System . out . p r i n t l n ("\nNumber o f i tems : " + checkout .
numberOfItems ( ) + "\n") ;

156 System . out . p r i n t l n ("\ nTotal co s t : " + checkout . t o ta lCos t ( )
+ "\n") ;

157 System . out . p r i n t l n ("\ nTotal tax : " + checkout . totalTax ( ) +
"\n") ;

158 System . out . p r i n t l n ("\ nCost + Tax : " + ( checkout . t o ta lCos t ( )
+ checkout . tota lTax ( ) ) + "\n") ;

159 System . out . p r i n t l n ( checkout ) ;
160 }
161 }

B.2 Disco Results
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